summaryrefslogtreecommitdiff
path: root/sys-process/btop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-process/btop
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-process/btop')
-rw-r--r--sys-process/btop/Manifest4
-rw-r--r--sys-process/btop/btop-1.2.7-r1.ebuild48
-rw-r--r--sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch17
-rw-r--r--sys-process/btop/metadata.xml16
4 files changed, 85 insertions, 0 deletions
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
new file mode 100644
index 000000000000..0229c2816e29
--- /dev/null
+++ b/sys-process/btop/Manifest
@@ -0,0 +1,4 @@
+AUX btop-1.2.7-respect-cxx-var-839318.patch 440 BLAKE2B eb2361ad5c594a29145265996bfe175d4929676dd9ec987b2a2e2df42bbe4ea031b40775c0eca6c2bcc6ded4def12625e178a4e007901a724a104ded20564653 SHA512 ced8210a9e2e6cfec90f1c1f4b72c969aa1b5943c16250c30139ab87eebc9e189583c98687036252a819698eccaed09149ec188150db7ce756ce4a90e4bca6e4
+DIST btop-1.2.7.tar.gz 974883 BLAKE2B c23c0b13ee6749e30ca8a7624f27bac8dc81466ff957a042c9c5e4f7c31b81fc6c15d6b214186e4baed474263ea96a3ffc584783cd098f3ebcae9e34bd75a955 SHA512 c29e1e3d098ef29c710bf76c1ef20e54feceb490aa59d20475a7083a276d422a32f4b4ff423a121aa4aa7f83389980e553e1f78c165f111fe00ccac693d96447
+EBUILD btop-1.2.7-r1.ebuild 980 BLAKE2B 24af8d3d1dcbf5125fbb64291a406c071e25fd0587b4702f415478525925753139670a9f66d8da29342e6b3d1fd1a1719fde8b3f06a68eb8f07ef7ed41d27c06 SHA512 a168c2fbf27f729108be1783937d58fd7cf854d866631e7b910c1550f1b28885170296f360097cea717dfa2219d6b2832aa31c55fe39d1d19fe7f060dad2008d
+MISC metadata.xml 548 BLAKE2B 74762cdc63011b363a4c06de8190541f862d70f0006461c7a1cf2d734caf20601ba0769dc067e261957fe42a64bdaf26297bf3d080c3c08203eabd73165f2f8c SHA512 bb16944df9321001ca5c9e9fff49ea39069386117f0cfde67e8f19e3f44c13d360effb578d2c44c67f792d1ff574830f13cb9ef183f594e39ad3669083f2cf41
diff --git a/sys-process/btop/btop-1.2.7-r1.ebuild b/sys-process/btop/btop-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..39adcfa15486
--- /dev/null
+++ b/sys-process/btop/btop-1.2.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A monitor of resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-respect-cxx-var-839318.patch"
+)
+
+src_prepare() {
+ default
+ # btop installs README.md to /usr/share/btop by default
+ sed -i '/^.*cp -p README.md.*$/d' Makefile || die
+}
+
+src_compile() {
+ # Disable btop optimization flags, since we have our flags in CXXFLAGS
+ emake OPTFLAGS="" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}" \
+ install
+
+ dodoc README.md CHANGELOG.md
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch b/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch
new file mode 100644
index 000000000000..5ec7dca45c1e
--- /dev/null
+++ b/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -55,11 +55,11 @@ endif
+
+ #? Compiler and Linker
+ ifeq ($(shell command -v g++-11 >/dev/null; echo $$?),0)
+- CXX := g++-11
++ CXX ?= g++-11
+ else ifeq ($(shell command -v g++11 >/dev/null; echo $$?),0)
+- CXX := g++11
++ CXX ?= g++11
+ else ifeq ($(shell command -v g++ >/dev/null; echo $$?),0)
+- CXX := g++
++ CXX ?= g++
+ endif
+ override CXX_VERSION := $(shell $(CXX) -dumpfullversion -dumpversion || echo 0)
+
diff --git a/sys-process/btop/metadata.xml b/sys-process/btop/metadata.xml
new file mode 100644
index 000000000000..a102c953b978
--- /dev/null
+++ b/sys-process/btop/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>nex+b-g-o@nexadn.de</email>
+ <name>Adrian Schollmeyer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aristocratos/btop</remote-id>
+ <bugs-to>https://github.com/aristocratos/btop/issues</bugs-to>
+ </upstream>
+</pkgmetadata>