summaryrefslogtreecommitdiff
path: root/sys-process/bpytop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sys-process/bpytop
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest3
-rw-r--r--sys-process/bpytop/bpytop-1.0.63.ebuild33
-rw-r--r--sys-process/bpytop/files/bpytop-1.0.63-tests.patch35
3 files changed, 71 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index a24d556e82c4..3c13ee8e865b 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1,4 +1,7 @@
AUX bpytop-1.0.61-tests.patch 768 BLAKE2B 9b5628081b134310dc0bddfc6bbc2c378ab0d28199434a816475b7db6f0a0aac32f8861b48fbfc56ae338b1d25882a06dbc9c3de233fe0b105bab711c251b2a8 SHA512 b024e338b81034d3c10ccb6fda5a6e942fbf3481caeb4384111f12cfec40ff3a28f009d45854f0daf04c2945256de8b6a77bcb9c0d3424e69fea056508c5c074
+AUX bpytop-1.0.63-tests.patch 1326 BLAKE2B bf35b34611964e005cdac75054ea2733309e68637df95c3df3c58cd076156b44c1f7dab45c986cde5fa02296efdebeff67d1f6955032f98fdf43c4ea27728e08 SHA512 b75f667226ce466305037b271060656edf08f2941351012cb02bf59048ae696c052d7a80de80932256728b256524dc8f778e8d449dc011432a54f8f8ba34ae73
DIST bpytop-1.0.61.tar.gz 626468 BLAKE2B 84a9bbaec6af27b06af53acbe2e735421de3bc4567fcf7fb29d05f801f7414b4e035e67a2fecb27a45d4d91c1d6ef527a16775f44c2e5620ecf797794969a2d2 SHA512 639e0d94bd500477b8288400c6fa1769f1b7327733bec8292e72eb3024e26f6242901970dfc539d9fb309f69299ea934e02ab93226f907ddbbefb670bffb027c
+DIST bpytop-1.0.63.tar.gz 627729 BLAKE2B a61d7c101c05d8e706b5c89f3c52dd02cf99e126d73f4cdb58adf8e474774e618abce7184a6fcf1c1b69f4c491b088c4c715d7b803c56933e1a8eeb8efa77fec SHA512 85334a43137466992fe3003f7f29b6a66b41732d1953fd5653ce277d35735127eef97607599906c0d0cfc7323852da75541b2ae79db22f843892097a2d3398e4
EBUILD bpytop-1.0.61-r1.ebuild 710 BLAKE2B 65f31779d8ec7541de778a046d05837bd30ae24222d47f1f6f71c1a740061e2402ca3b157503aa167068f94e963c14243f6c23bc8396e983ad10923e5420cd51 SHA512 493910aaa46a19175de31abb3a1c91fc1b250f3a5ba1c3d7ed309b32ce7c05248b6ebe973eaae614fd84fe559bcf108e9ee1a19eaa5fad6bec005c04d3c18b2e
+EBUILD bpytop-1.0.63.ebuild 710 BLAKE2B 5bf551615b28e84e1dac73120077a2c9c4b5a3af96bf0397f577bd4b8c2a8e62b315bd345422d30219f1e4b0913cec2910c54b9665117bf55ad8895fc523188c SHA512 b03eaccbdc0294db021282bf4440d23bae362a86bb1a329be830f8187a63110fad7c996e58ab1842f7eddd0660835a66a54503d948a0f672b4e0d1f07bde69e1
MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/sys-process/bpytop/bpytop-1.0.63.ebuild b/sys-process/bpytop/bpytop-1.0.63.ebuild
new file mode 100644
index 000000000000..5b1ac4dd6d6a
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.63.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.63-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}
diff --git a/sys-process/bpytop/files/bpytop-1.0.63-tests.patch b/sys-process/bpytop/files/bpytop-1.0.63-tests.patch
new file mode 100644
index 000000000000..3085c3e19ef5
--- /dev/null
+++ b/sys-process/bpytop/files/bpytop-1.0.63-tests.patch
@@ -0,0 +1,35 @@
+diff --git a/bpytop.py b/bpytop.py
+index 16482c0..a2b18d6 100755
+--- a/bpytop.py
++++ b/bpytop.py
+@@ -63,16 +63,21 @@ args.add_argument("-b", "--boxes", action="store", dest="boxes", help = "which
+ args.add_argument("-lc", "--low-color", action="store_true", help = "disable truecolor, converts 24-bit colors to 256-color")
+ args.add_argument("-v", "--version", action="store_true", help = "show version info and exit")
+ args.add_argument("--debug", action="store_true", help = "start with loglevel set to DEBUG overriding value set in config")
+-stdargs = args.parse_args()
+
+-if stdargs.version:
+- print(f'bpytop version: {VERSION}\n'
+- f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
+- raise SystemExit(0)
+-
+-ARG_BOXES: str = stdargs.boxes
+-LOW_COLOR: bool = stdargs.low_color
+-DEBUG: bool = stdargs.debug
++if __name__ == "__main__":
++ stdargs = args.parse_args()
++ if stdargs.version:
++ print(f'bpytop version: {VERSION}\n'
++ f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
++ raise SystemExit(0)
++
++ ARG_BOXES: str = stdargs.boxes
++ LOW_COLOR: bool = stdargs.low_color
++ DEBUG: bool = stdargs.debug
++else:
++ ARG_BOXES = None
++ LOW_COLOR = False
++ DEBUG = False
+
+ #? Variables ------------------------------------------------------------------------------------->
+