summaryrefslogtreecommitdiff
path: root/sys-process/bashtop/bashtop-0.9.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-process/bashtop/bashtop-0.9.25.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-process/bashtop/bashtop-0.9.25.ebuild')
-rw-r--r--sys-process/bashtop/bashtop-0.9.25.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-process/bashtop/bashtop-0.9.25.ebuild b/sys-process/bashtop/bashtop-0.9.25.ebuild
new file mode 100644
index 000000000000..c92ad3eeb807
--- /dev/null
+++ b/sys-process/bashtop/bashtop-0.9.25.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Resource monitor that shows usage and stats"
+HOMEPAGE="https://github.com/aristocratos/bashtop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i -e 's/local//g' Makefile || die "Editing path failed"
+ sed -i -e '/DOCDIR/d' Makefile || die "Removing doc folder failed"
+}
+
+pkg_postinst() {
+ optfeature "CPU Temperature support" sys-apps/lm-sensors
+ optfeature "Update news and Theme Download feature" net-misc/curl
+ optfeature "Disk Stats support" app-admin/sysstat
+}