summaryrefslogtreecommitdiff
path: root/sys-power
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /sys-power
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/Manifest.gzbin5060 -> 5061 bytes
-rw-r--r--sys-power/switcheroo-control/Manifest1
-rw-r--r--sys-power/switcheroo-control/switcheroo-control-2.6-r2.ebuild71
3 files changed, 72 insertions, 0 deletions
diff --git a/sys-power/Manifest.gz b/sys-power/Manifest.gz
index 67739894f984..7b91c9ecc530 100644
--- a/sys-power/Manifest.gz
+++ b/sys-power/Manifest.gz
Binary files differ
diff --git a/sys-power/switcheroo-control/Manifest b/sys-power/switcheroo-control/Manifest
index 308be70a5b5b..7815642210d9 100644
--- a/sys-power/switcheroo-control/Manifest
+++ b/sys-power/switcheroo-control/Manifest
@@ -1,5 +1,6 @@
AUX switcheroo-control-init.d 240 BLAKE2B 00fd91de3da9e59fdf0f073a3a9f89ac6fee9cbc9941da2b44be62c0eca79562b3a9cb123ef86237d3be25f1c5ce3f293fb4814e023da110bb7faae0218c7037 SHA512 0f70d93839d68f09b07d96ae397e41d086500c55cca358125002991280bcd6471e5870ba2a8f696201deaee3403093156ae123804fd9649483cfd5655f887299
DIST switcheroo-control-2.6.tar.xz 29996 BLAKE2B 98204a1d0f3b92cc2b98ad9f382313aed4da5877ac6be607c48ee9386bd25087301e249907a7e1385eea357f0a3ce5fb2936fac688923dfa3555a9870f0d2e58 SHA512 ac8867a839ae958676f5c5c7bb4c25cbbcf70eb35a696bb3d80b388c31a9722e75311c041c4c60b8f1d00f405af97dd9173e99780a2be3c621ac759c4986a2d2
EBUILD switcheroo-control-2.6-r1.ebuild 1448 BLAKE2B b667bf038d952914bd9ec699b9565a36e2c608ff0093215e6aa09d0ec149d10c5660b113ae217139dd3bc4976864b3c09f2dd2698f96ee4c977dd5c3d47ca41f SHA512 163ec56db3186d79039dd47de02ccfd71bea534f4923c0bb31c1a9a3f20273686d1c3bc6f6a729758de67c24e78dab656e55bfdcc911cfb5435f3488373d8201
+EBUILD switcheroo-control-2.6-r2.ebuild 1771 BLAKE2B 66c147749b12ef8cf92ba472c5fcf7714c281951096fcf02203be31adb5fd329f35b989ba6df5b8a9ca73e8879b09464f7cccdc153fe785891fcab6ce03870e6 SHA512 3ab13fa8142d3dfa675d385ed96cdaabf45cf219a8316ad4940d299723ea5cc909e51c5acd704570fd6e49270ae1283934d0ff33b474b2b536308041ef433d2f
EBUILD switcheroo-control-2.6.ebuild 1187 BLAKE2B 47477f68144b7d9c13c50b45194887a0ca2db84cfb6a3d947d0da51a38ad2bc07c1b5010226d043f9912e27f6cb9a81f9d10c5fdf2b07d838623a15704691679 SHA512 45ca31bbf8fb3bd313ee9a5b754d219ae4ed4bb17d88bfeaf89b86234d2167c4312ab93390cddf15641c570c133c46f57d48544705f855f02f1fcaf78357613e
MISC metadata.xml 319 BLAKE2B a3d0c3eb8684beca028aa1a168ffd796db835207225c2e3979bf3d0cadb99e96bc774aa2598356df483597a87a7bf4cd5c3b0ba7cffd3b4c2e1faa0d37c9cb9a SHA512 68760ca73834ff5f65c898d935dc4ece52b2f54b5501457433f92a8d93a48f4e3baac188e22b1a65d990b13abad2f7463f8d8ce2c286bdf172841fd46c023a18
diff --git a/sys-power/switcheroo-control/switcheroo-control-2.6-r2.ebuild b/sys-power/switcheroo-control/switcheroo-control-2.6-r2.ebuild
new file mode 100644
index 000000000000..904ca86aeeaa
--- /dev/null
+++ b/sys-power/switcheroo-control/switcheroo-control-2.6-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 systemd
+
+DESCRIPTION="D-Bus service to check the availability of dual-GPU"
+HOMEPAGE="https://gitlab.freedesktop.org/hadess/switcheroo-control/"
+SRC_URI="https://gitlab.freedesktop.org/hadess/switcheroo-control/uploads/86ea54ac7ddb901b6bf6e915209151f8/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="gtk-doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/libgudev-232:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ dev-util/gdbus-codegen
+ gtk-doc? ( dev-util/gtk-doc )
+ test? (
+ $(python_gen_cond_dep 'dev-python/python-dbusmock[${PYTHON_USEDEP}]')
+ dev-util/umockdev
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ else
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/switcherooctl
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You to enable the service:"
+ if systemd_is_booted; then
+ elog "# systemctl enable switcheroo-control"
+ else
+ elog "# rc-update add ${PN} default"
+ fi
+ fi
+}