summaryrefslogtreecommitdiff
path: root/sys-power
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 15:29:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 15:29:04 +0100
commit27c1d146e5ee9e472a31a7958ad4dc70a5451ea7 (patch)
treefe573cd3516126d757c143a469871b88e5851548 /sys-power
parentbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (diff)
gentoo auto-resync : 02:06:2023 - 15:29:04
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/Manifest.gzbin5066 -> 5065 bytes
-rw-r--r--sys-power/acpi_call/Manifest4
-rw-r--r--sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild (renamed from sys-power/acpi_call/acpi_call-1.2.2.ebuild)15
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild15
4 files changed, 16 insertions, 18 deletions
diff --git a/sys-power/Manifest.gz b/sys-power/Manifest.gz
index 52d3f54b1637..8e71ddcdd457 100644
--- a/sys-power/Manifest.gz
+++ b/sys-power/Manifest.gz
Binary files differ
diff --git a/sys-power/acpi_call/Manifest b/sys-power/acpi_call/Manifest
index 72b4d0cc4630..ecc35c1bb690 100644
--- a/sys-power/acpi_call/Manifest
+++ b/sys-power/acpi_call/Manifest
@@ -1,4 +1,4 @@
DIST acpi_call-1.2.2.tar.gz 12403 BLAKE2B 3195ec7e4d6189abdbb1409914d97d481f63ec79ec89a2ab630120ea99aabf8ca5890c500149a386a4a661d17e58387a6b252b625b6abadef1d977691156745e SHA512 3916a211bcc4a2435c6ba9664b1c86d8ab587c052a03e6edccd00fd7d01c6a756003dcc146e22e2cf688795600589c8cac1d83774c989794dcadc91f5caa2b5e
-EBUILD acpi_call-1.2.2.ebuild 695 BLAKE2B 8df9796c1c8c2d66d2a0e02b42170477abae9fe39cacb914a026e06b52289dfa222d72780fa82679b4ac73fb7b1363f0342702a70f97ad1b5631c9f01b106c70 SHA512 d924f609372a0965218a2bbb0380403a71b0207863e5f16938495e62948cda4e10c769a9950f1b3dba8272f4923964f2e1c6072e261ddd179afc0f1ef3097071
-EBUILD acpi_call-9999.ebuild 670 BLAKE2B 02dd23b77eb28cf9425e3039c61f594a044c0dd7bd4ded1c91d70bb2a970e0b7b5adebe4c6ead52ec3fdabeae1ff5bb69c5cb980d452804e1966ed6c2d510a63 SHA512 7ee0c7e030b5494c94b4e74c85c29bb31a579db2f9a3bb67e0c5ca4edd3da5511a6aba1a8ee78ab430440a58a23ea1e3afc8e8b0f5bdaae1738c77c29aaf626f
+EBUILD acpi_call-1.2.2-r1.ebuild 663 BLAKE2B 3e3b6b9abd1165d8a5990cba90fdd222306726be9282d2a1469b6cd8fc8fda101263f443379004d2f273e91d03292c8e5aad1ba2012231c407b6184a3ab0a8f4 SHA512 3774313eca40cdb19fa7ba068ee8a1b2db020cfe3abc9fe76aca1d81e0569160ccdd1adf0cd1c893815d08c13f7fb194f229b7dff6f841bc3223388ab35fd06c
+EBUILD acpi_call-9999.ebuild 638 BLAKE2B 7f4b2f82975006d8bd9f975c5bdb3e99d51486fa53bb2c6bb9b31d75d7f5f430e7c878efd3737825b13120ec6283f84e39c58b38046ccb1d673b90c90d5ddacf SHA512 3c860d9b5aed261ec773710585cf8080adf03e92c96142920d338b89463f6496bfdd5b8e09bb8ee84b62848d6b93c23e7de81d275afb970cf1bfab8e8ab7e9b4
MISC metadata.xml 410 BLAKE2B 5ebcbe3474317a93bdc9b8bd8c033300de713d3906638585d8296262c084f7101ca189edd5cc8bcfeaeba6dea68ca75f7349a5e189f94da4dfa85145c939767b SHA512 fbd1f13cfdfa756b2feb04e8b426e8e26eb835d037833aa0dac48aa1ed1f88f0ce985ff3812282298c9fb533279dfaab8bf8cd79852dbb0b1953d7d0209f7985
diff --git a/sys-power/acpi_call/acpi_call-1.2.2.ebuild b/sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild
index 90e2e0158a01..b7fd9601068a 100644
--- a/sys-power/acpi_call/acpi_call-1.2.2.ebuild
+++ b/sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-info linux-mod
+inherit linux-mod-r1
DESCRIPTION="A linux kernel module that enables calls to ACPI"
HOMEPAGE="https://github.com/nix-community/acpi_call"
@@ -14,18 +14,17 @@ SLOT="0"
KEYWORDS="amd64"
IUSE="examples"
-BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
-MODULE_NAMES="acpi_call(misc:${S})"
src_compile() {
- BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ local modargs=( KDIR=${KV_OUT_DIR} )
+ local modlist=( acpi_call=misc )
- linux-mod_src_compile
+ linux-mod-r1_src_compile
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
if use examples; then
insinto /usr/share/acpi_call
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
index ba449334ffc0..c8b96da325e2 100644
--- a/sys-power/acpi_call/acpi_call-9999.ebuild
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 linux-info linux-mod
+inherit git-r3 linux-mod-r1
DESCRIPTION="A linux kernel module that enables calls to ACPI"
HOMEPAGE="https://github.com/nix-community/acpi_call"
@@ -14,18 +14,17 @@ SLOT="0"
KEYWORDS=""
IUSE="examples"
-BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
-MODULE_NAMES="acpi_call(misc:${S})"
src_compile() {
- BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ local modargs=( KDIR=${KV_OUT_DIR} )
+ local modlist=( acpi_call=misc )
- linux-mod_src_compile
+ linux-mod-r1_src_compile
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
if use examples; then
insinto /usr/share/acpi_call