summaryrefslogtreecommitdiff
path: root/sys-power
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-20 20:42:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-20 20:42:12 +0100
commit188aafb7c559528cc9c47d6d508c322f6e33adb5 (patch)
treeff1a6e0ce1e25757129e0b181acb6df3bdf775ba /sys-power
parentd4b912f35e71cc281dcca92af83eb059d8a0fe0a (diff)
gentoo auto-resync : 20:07:2022 - 20:42:12
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/Manifest.gzbin5066 -> 5067 bytes
-rw-r--r--sys-power/switcheroo-control/Manifest2
-rw-r--r--sys-power/switcheroo-control/switcheroo-control-2.6.ebuild53
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-power/Manifest.gz b/sys-power/Manifest.gz
index 9c391a612ece..fe305dc55346 100644
--- a/sys-power/Manifest.gz
+++ b/sys-power/Manifest.gz
Binary files differ
diff --git a/sys-power/switcheroo-control/Manifest b/sys-power/switcheroo-control/Manifest
index fb3a96df5224..7d0b0c24799a 100644
--- a/sys-power/switcheroo-control/Manifest
+++ b/sys-power/switcheroo-control/Manifest
@@ -1,3 +1,5 @@
DIST switcheroo-control-2.4.tar.xz 27964 BLAKE2B f85014ad6696e301bafd75b694f5c130498171d95b0330d2996568737cbcd677eef5256bc47638bf87d178d6fe099f3c53bd710a1534db20f1dbe5fbe51681c7 SHA512 47f071b17cbb520d862800ef2d8389ada1130be96a8c1efed9be6793081b5826355ad30b0feeba1cc9eda792b4c943ffc852d12648b0c5e74f25c207d151c1c3
+DIST switcheroo-control-2.6.tar.xz 29996 BLAKE2B 98204a1d0f3b92cc2b98ad9f382313aed4da5877ac6be607c48ee9386bd25087301e249907a7e1385eea357f0a3ce5fb2936fac688923dfa3555a9870f0d2e58 SHA512 ac8867a839ae958676f5c5c7bb4c25cbbcf70eb35a696bb3d80b388c31a9722e75311c041c4c60b8f1d00f405af97dd9173e99780a2be3c621ac759c4986a2d2
EBUILD switcheroo-control-2.4.ebuild 917 BLAKE2B 6bd3ab227424ef1e6ec1efd9d8383f353c076c5bbbe0bbf0875e5f22cada2f8ee42631c2eb793bd4bbd6ad7070a5404adc0b484901271ae26bedac0f74b14b67 SHA512 199a464108ba28b19059539888eb0dea7c9cb33018a8727479b088d3bf6924f48d8820bd90fed882d36ff2127c9f0e4660621df5738c65638319090550ff1712
+EBUILD switcheroo-control-2.6.ebuild 1181 BLAKE2B ee6659610a4387b42063b85bb5809521b81c5872425fa72d5ebabdb6407e4b990abb3da592653d01d1503f950720fedcd7a06f8748097ea0cf2ed3a758af7468 SHA512 1e2ee83ff32c7064c3b4bae74e73646f88b143c62a9ef8dd25d42f96c71acc10607f93ce18fb2f133cf712f2dbd4006e10f548fa510e5d13230c29a2bef73327
MISC metadata.xml 217 BLAKE2B f8189b02494f180dac078dcd5c275d3c795f20f360f8b172c66065a2d937e396b24b8631bba4cd8567d60285ce89fc77b9539f2233bf33899c820613c48c33ba SHA512 f0c9e5b3d281fecd21b1e23a6f44c94c1c0b3220de46a177d35932111b7f1ab4399061c42833ac1ee9bd0324b139fc8db66e0d2890224d607bd3be38ae469be9
diff --git a/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild b/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild
new file mode 100644
index 000000000000..93e64ab5b467
--- /dev/null
+++ b/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="D-Bus service to check the availability of dual-GPU"
+HOMEPAGE="https://gitlab.freedesktop.org/hadess/switcheroo-control/"
+SRC_URI="https://gitlab.freedesktop.org/hadess/switcheroo-control/uploads/86ea54ac7ddb901b6bf6e915209151f8/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="gtk-doc test"
+
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/libgudev-232:=
+ sys-apps/systemd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ test? (
+ $(python_gen_any_dep 'dev-python/python-dbusmock[${PYTHON_USEDEP}]')
+ dev-util/umockdev
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+python_check_deps() {
+ use test || return 0
+ has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You need to run systemd and enable the service:"
+ elog "# systemctl enable switcheroo-control"
+ fi
+}