summaryrefslogtreecommitdiff
path: root/sys-power/tlp/tlp-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 07:41:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 07:41:53 +0100
commit4b91667ebe695e6fdfbef3962d099f17484b8806 (patch)
tree0af842488d683612bd9eae3f406ec839bcbc0cf9 /sys-power/tlp/tlp-1.5.0.ebuild
parentb89a664f266dab3b9b5ddac2cb874f8869142370 (diff)
gentoo auto-resync : 13:10:2022 - 07:41:53
Diffstat (limited to 'sys-power/tlp/tlp-1.5.0.ebuild')
-rw-r--r--sys-power/tlp/tlp-1.5.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-power/tlp/tlp-1.5.0.ebuild b/sys-power/tlp/tlp-1.5.0.ebuild
new file mode 100644
index 000000000000..58c6a1db7a7d
--- /dev/null
+++ b/sys-power/tlp/tlp-1.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev optfeature
+
+DESCRIPTION="Optimize laptop battery life"
+HOMEPAGE="https://linrunner.de/tlp/"
+SRC_URI="https://github.com/linrunner/TLP/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/TLP-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It's uncertain if elogind/systemd is actually required, however, without the sleep
+# hooks working, which require one of them, it doesn't seem like this app is very useful.
+RDEPEND="
+ dev-lang/perl
+ virtual/udev
+ || ( sys-auth/elogind sys-apps/systemd )
+"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TLP_NO_INIT=1 \
+ TLP_WITH_ELOGIND=1 \
+ TLP_WITH_SYSTEMD=1 \
+ install install-man
+
+ fperms 444 /usr/share/tlp/defaults.conf # manpage says this file should not be edited
+ newinitd "${FILESDIR}/tlp.init" tlp
+ keepdir /var/lib/tlp # created by Makefile, probably important
+}
+
+pkg_postinst() {
+ udev_reload
+
+ optfeature "disable Wake-on-LAN" sys-apps/ethtool
+ optfeature "see disk drive health info in tlp-stat" sys-apps/smartmontools
+}
+
+pkg_postrm() {
+ udev_reload
+}