summaryrefslogtreecommitdiff
path: root/sys-power/switcheroo-control
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-power/switcheroo-control
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-power/switcheroo-control')
-rw-r--r--sys-power/switcheroo-control/Manifest3
-rw-r--r--sys-power/switcheroo-control/metadata.xml7
-rw-r--r--sys-power/switcheroo-control/switcheroo-control-2.4.ebuild39
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-power/switcheroo-control/Manifest b/sys-power/switcheroo-control/Manifest
new file mode 100644
index 000000000000..77e7403a6c6d
--- /dev/null
+++ b/sys-power/switcheroo-control/Manifest
@@ -0,0 +1,3 @@
+DIST switcheroo-control-2.4.tar.xz 27964 BLAKE2B f85014ad6696e301bafd75b694f5c130498171d95b0330d2996568737cbcd677eef5256bc47638bf87d178d6fe099f3c53bd710a1534db20f1dbe5fbe51681c7 SHA512 47f071b17cbb520d862800ef2d8389ada1130be96a8c1efed9be6793081b5826355ad30b0feeba1cc9eda792b4c943ffc852d12648b0c5e74f25c207d151c1c3
+EBUILD switcheroo-control-2.4.ebuild 851 BLAKE2B 51ee108b4e95daa88f1f6d328bfbb1b05154e2e53cbb053423b0084c8352b887bc73d8fe04193c8534f36b330d367fb4f7aeb5418507aaacd431f9f76beb287f SHA512 e018f0087a28bb6b413773374af814fad047e95b73111eba65af697cfb7e154908e308fd8b47370703faa304be6b67b43aefbd3a424285b8c6321e01853ab4d7
+MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/sys-power/switcheroo-control/metadata.xml b/sys-power/switcheroo-control/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/sys-power/switcheroo-control/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-power/switcheroo-control/switcheroo-control-2.4.ebuild b/sys-power/switcheroo-control/switcheroo-control-2.4.ebuild
new file mode 100644
index 000000000000..9712cad1e582
--- /dev/null
+++ b/sys-power/switcheroo-control/switcheroo-control-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson
+
+DESCRIPTION="D-Bus service to check the availability of dual-GPU"
+HOMEPAGE="https://gitlab.freedesktop.org/hadess/switcheroo-control/"
+SRC_URI="https://gitlab.freedesktop.org/hadess/switcheroo-control/uploads/accd4a9492979bfd91b587ae7e18d3a2/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="gtk-doc"
+
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/libgudev-232:=
+ sys-apps/systemd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You need to run systemd and enable the service:"
+ elog "# systemctl enable switcheroo-control"
+ fi
+}