summaryrefslogtreecommitdiff
path: root/sys-power/suspend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /sys-power/suspend
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'sys-power/suspend')
-rw-r--r--sys-power/suspend/Manifest1
-rw-r--r--sys-power/suspend/suspend-1.0_p20150810-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-power/suspend/Manifest b/sys-power/suspend/Manifest
index b81b5693197a..344a8e4f100c 100644
--- a/sys-power/suspend/Manifest
+++ b/sys-power/suspend/Manifest
@@ -1,4 +1,5 @@
DIST suspend-1.0_p20120915.tar.xz 111080 BLAKE2B 99eea1d9808219373501001f0af90973c9176c1b19d62bff7be26886b11ebb514134b68434e9b453146ef1a4af2c4cc8e26326b956a1b2378c38c100638af17c SHA512 bb714b4a7c0f5749c4b711a5c38ca5d8cb5078176a75387957123f75cfe8348adc3aa4e96335eb65c14ad1dd2f99fd6dbca3b415525dd39b3c547f9b13b775be
DIST suspend-1.0_p20150810.patch.xz 6172 BLAKE2B 026aee69c59119b2d51ec1bf396633b2a3df018c95eecc53106a2d99017169a95951f8296a4962b32e5ea4c8d8cf4ea77f693367866137390048bc137456fe4d SHA512 cb186bdb0619ed4852e2ba12d6048f26fa23c7556d7c95713f14a4258fbb014bbec2281edee6478ebf5916600b674d47d8ba53e7644391de933b03e9fd1b96e9
+EBUILD suspend-1.0_p20150810-r1.ebuild 1238 BLAKE2B 59622315e2d58d9964c25f32c3822015291a9fadc5172607231d148faea005cfab097f4715a9d8ae903889aa67517529095526e6abee5d1a1dbfd77fe84d8dc6 SHA512 72088eb67fb794ca2baeed5f2a9b574068f959bacf58509eb5314e84a2a1807c17648f1c82e21149a277b97e37c5065c92f88369c7736e6d1b78af34376fd37b
EBUILD suspend-1.0_p20150810.ebuild 1286 BLAKE2B 0217a2b49bdc85b6eeecef46c4c2c265d724b25910429b752d78fbd69ad2241ad15a55c688b0e4d0bf3ff37fdc94f221d8f06a5d13b2c2de39f8300375b1b968 SHA512 0908b597b3e30c527538c54531071076282047b4b4da1c8997aebbb2ae29eb9066fa6bb91e57064e6ae5f3e972f1e0d6c23086a589a8d6b73c62602745c343a0
MISC metadata.xml 586 BLAKE2B 0b15707bf6ff21ec70345f9e6f06f55ec979410dc6a49ddf6bfe4124f2db02a515932a845dd0ceabf6ddfdd894cbd90909c3dc60d7593978fe9c73db169b0a98 SHA512 fea00b4ea8510e8b10482a5956d585b96638a9f530eae8248e83c2cf9316fc5a37769b3eb080d09182ed6d7d34e46c1f3a9939ad28c7a176c35d2dfdecb7f4b4
diff --git a/sys-power/suspend/suspend-1.0_p20150810-r1.ebuild b/sys-power/suspend/suspend-1.0_p20150810-r1.ebuild
new file mode 100644
index 000000000000..14c95b47135a
--- /dev/null
+++ b/sys-power/suspend/suspend-1.0_p20150810-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+BASE_PV="1.0_p20120915"
+
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${PN}-${BASE_PV}.tar.xz
+ https://dev.gentoo.org/~bircoph/patches/${P}.patch.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt +lzo threads"
+
+RDEPEND="
+ dev-libs/libx86
+ >=sys-apps/pciutils-2.2.4
+ crypt? (
+ >=dev-libs/libgcrypt-1.6.3:0[static-libs]
+ dev-libs/libgpg-error[static-libs] )
+ lzo? ( >=dev-libs/lzo-2[static-libs] ) "
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lang/perl-5.10
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${WORKDIR}/${P}.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --disable-fbsplash \
+ $(use_enable crypt encrypt) \
+ $(use_enable lzo compress) \
+ $(use_enable threads)
+}
+
+src_install() {
+ dodir etc
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/share/doc/${PF}"/COPYING* || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=156445"
+}