summaryrefslogtreecommitdiff
path: root/sys-power/nvram-reboot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-power/nvram-reboot
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-power/nvram-reboot')
-rw-r--r--sys-power/nvram-reboot/Manifest5
-rw-r--r--sys-power/nvram-reboot/metadata.xml11
-rw-r--r--sys-power/nvram-reboot/nvram-reboot-2004.10.03.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/sys-power/nvram-reboot/Manifest b/sys-power/nvram-reboot/Manifest
new file mode 100644
index 000000000000..147429f78bd1
--- /dev/null
+++ b/sys-power/nvram-reboot/Manifest
@@ -0,0 +1,5 @@
+DIST reboot-2004.10.03.tar.bz2 425622 SHA256 775dc675849a2eb7f4b01608bb4dfc2c55eab72ac7373c82adda1c4ba296f47f SHA512 b85a7372369f3ba9e36af1b96ccbf31ba1febcc3ebf31a8684332d370ea85428a3bfc4855c7df10f9b92a3c57b704fabbe5069a792cd8aaa1b45511f88c41906 WHIRLPOOL 5aedfcb448831d094268de243cbe533c45baa7d95c449cd4d6662bebe61665058370a1755716d2376f5c065e34100d5f6b9d94fcac8aac34b9b5e7195090d5ee
+EBUILD nvram-reboot-2004.10.03.ebuild 599 SHA256 ecb0fafcb9a4c460cadb257d72a1bafb347dbd51a53a31927f34c4a51715660d SHA512 74d304061fd0a20876f8bf897d38645cf1ad24a33a32782d3346e6ee19b64c634cfc2ce13326bf90fb5dc4e38080fe624dac8db29fffdb90628fe02490292a79 WHIRLPOOL e2864ae0872b601e122f6ec8133c8b04af030850caebd3fc81be08580b999b10ace7e208b4a5935a972d348d4e14f9215b026d3e82519ef18445431557c3febc
+MISC ChangeLog 3076 SHA256 3b5c495a421bda2c9cdbef7befcf64a463c00c49b4ae1896079d59e885a76b96 SHA512 b0afed0beca1c110886ca7fdd7eddc1c4b6c0aa7742447dd2e7e14d46be4d2e870a1d7545f91e6898107110a0ca4991ebca8bdb17dd42c06a538228518906f01 WHIRLPOOL d878a4d43355c494fd7243808c6f251c0217b3218e3ce8e276e3cae532f086b94d486ac7ddc5dfe9152318a2cb059d1338f8e47d615b9bdcc319d8affe9f895b
+MISC ChangeLog-2015 840 SHA256 2b3b1a45ed11d36202969da00792ccdb219a5e9bc96253015c20ce5bc941615c SHA512 efb211720c2ec849158e7d74120ffdb76c86bb3d4b83be1b4edbdaa64198edd1b080281c2c400d9dc38015bbc037ff94d742a249fc9e388ae41986a303e1b2e8 WHIRLPOOL 6ac71b0b368d5e3a5e483b656a4c74a27ca07f1b8631fbf88f7d86fc9b18f1e1da5bee751b068a24b8c234027caeb0487909d6c6b073bf1ee3e5cafb51ade886
+MISC metadata.xml 332 SHA256 355dceaf4f6713b4ba803f8bdd348ad077ce2b6178cee7af0a558950d9e78348 SHA512 948648cf4b193094ffe04b679d159ea2acf4a42d5005792889b782d56fc96cccdd87ba2b92ed5eade664a379107a1ee3a2a197c6dd69b531c395ebdf38229ebb WHIRLPOOL 652ae11b8c43da2bac9d3df288c7338943d7f13c06cb63bf7580fb6582455b36d94054cfe119274c5cc5e205b4bf52a92b21a3665e735892ad57d2f3047f65ea
diff --git a/sys-power/nvram-reboot/metadata.xml b/sys-power/nvram-reboot/metadata.xml
new file mode 100644
index 000000000000..0b3a391b3d5d
--- /dev/null
+++ b/sys-power/nvram-reboot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">nvram-wakeup</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/sys-power/nvram-reboot/nvram-reboot-2004.10.03.ebuild b/sys-power/nvram-reboot/nvram-reboot-2004.10.03.ebuild
new file mode 100644
index 000000000000..8d3bff58e842
--- /dev/null
+++ b/sys-power/nvram-reboot/nvram-reboot-2004.10.03.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit mount-boot
+
+MY_P="${P/nvram-/}"
+DESCRIPTION="PowerOff Boot-Images for nvram-wakeup (not needed for GRUB)"
+HOMEPAGE="https://sourceforge.net/projects/nvram-wakeup/"
+SRC_URI="mirror://sourceforge/nvram-wakeup/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /boot/nvram-wakeup
+ doins apm-poweroff.bin bzImage.2.4.20.poweroff dioden-poweroff \
+ || die "doins"
+ dodoc *.patch *.diff *.txt config.*
+}