summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 06:45:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 06:45:54 +0000
commite96f09a840f1ac865c504febe44bad831c63750e (patch)
treef90205e098da21eaed94d5234b156975e4a7a31c /sys-libs
parent6c988f4ed171aed46326587a0ec0d64297b20f49 (diff)
gentoo auto-resync : 11:03:2024 - 06:45:54
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin14725 -> 14729 bytes
-rw-r--r--sys-libs/libxcrypt/Manifest1
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.36-r3.ebuild254
3 files changed, 255 insertions, 0 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index b033aede72af..4458424c39c9 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/libxcrypt/Manifest b/sys-libs/libxcrypt/Manifest
index 40a4effd5e59..0ffffc5542f9 100644
--- a/sys-libs/libxcrypt/Manifest
+++ b/sys-libs/libxcrypt/Manifest
@@ -1,5 +1,6 @@
AUX libxcrypt-4.4.19-multibuild.patch 303 BLAKE2B cd342eef2a8ce3e305e544d37373370748690878b4171709028b7b894ad2c76c9188496ab089a46645ad6f9fca09fa4f89cdcb444e1400747ee358c079441661 SHA512 3cbd4bbd0827801faaaa2198eccccb285100cdfc43525b70816121aa70b32dc2c8479c53e16b9e99920926b1b11014dcc19909c4f72a09d9d19fcdb0fa6350cd
DIST libxcrypt-4.4.36-autotools.tar.xz 624660 BLAKE2B 8dc3d0f354baf8c64dc011e95e7df10d48b0dfe428503936ffd55edf2745de04003c7efe231ed5d9a14cea7f682ba377b7e00f0463b4060c50c9c29f555b790f SHA512 fb8391ecb89622eb0d74d13c5fc1369718e83c47671449044ca0c2f78a236d7b06177a60bf8cda47694caa840c68eaaf0b23690e8975fa5d64b734c8eb246d10
EBUILD libxcrypt-4.4.36-r2.ebuild 9083 BLAKE2B 75bae6bbaa6d87d2a7dde7c237e6e9d931adab44591a54d35e13f95993077d0cb16391fc85835ee67ffd6c30f88e052e24d4b5ecf6ea2833d56e0a1990401162 SHA512 a5fd4cdf5a9adc31e145109532181a659e4ddedbea7e7e3f74a47cb9afbcdbbcc1940f339cec2318fe7f34531b32d80f884e8e7db1b638dafede1493a987708c
+EBUILD libxcrypt-4.4.36-r3.ebuild 6520 BLAKE2B 6db30204a2815cf03a154bd542cc4039036c2613843f49dcab6aeae125a486d0aec9b2a250c8719bef368b92e13c96897716314d30efcf6892c23a0d7598775c SHA512 f538e1a5138c3e19be822a9040ac32b210dd3b7325fa170bf85d91ffe764db9a3a260317ab5f0fd9b5ff310c26ce0e1a4de302423b04637e2a0e5adc4e21d2ce
EBUILD libxcrypt-4.4.36.ebuild 9276 BLAKE2B 98a592ac762240cae507fc801b23df1172552d07a1583ef42d83efe00d1008f2fdc28cc71d73d527cb94d59ccd9db64062077789dece2428518b887bc72ba8a0 SHA512 8b4bf70219e81777d4ba975f0d06f33f9fda18211816e93f0b04363663a06fc2fad9cf1f02c012ca877935f45f6ea9af3afa026c56c12e7f5a97699097b975c3
MISC metadata.xml 913 BLAKE2B c2b3f52bd72bb46b0de4eb4a5f47dcb3aacfd248b811bcdc88db88c6f9cbe3ed1af4fda3e643b350fd22131273af03f2f888d78d306f0f7274d9432eb65075a3 SHA512 0ebbc3c2aa661f1a40e7f654384a395662b1b0235f145c7778b7b86bfb65ad09d4e8900bc6ede94413f057e769397c355bfd1bcafe8540acbf7e00e5451400c9
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.36-r3.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.36-r3.ebuild
new file mode 100644
index 000000000000..3faec08e8e41
--- /dev/null
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.36-r3.ebuild
@@ -0,0 +1,254 @@
+# Copyright 2004-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+# NEED_BOOTSTRAP is for developers to quickly generate a tarball
+# for publishing to the tree.
+NEED_BOOTSTRAP="no"
+inherit crossdev multilib python-any-r1 flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others"
+HOMEPAGE="https://github.com/besser82/libxcrypt"
+if [[ ${NEED_BOOTSTRAP} == "yes" ]] ; then
+ inherit autotools
+ SRC_URI="https://github.com/besser82/libxcrypt/releases/download/v${PV}/${P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-autotools.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+ public-domain BSD BSD-2"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+compat static-libs +system test headers-only"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ system? (
+ elibc_glibc? (
+ ${CATEGORY}/glibc[-crypt(-)]
+ !${CATEGORY}/glibc[crypt(-)]
+ )
+ elibc_musl? (
+ ${CATEGORY}/musl[-crypt(+)]
+ !${CATEGORY}/musl[crypt(+)]
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
+}
+
+pkg_pretend() {
+ if has "distcc" ${FEATURES} ; then
+ ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
+ ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
+ fi
+}
+
+pkg_setup() {
+ :
+}
+
+src_prepare() {
+ default
+
+ # WARNING: Please read on bumping or applying patches!
+ #
+ # There are two circular dependencies to be aware of:
+ # 1)
+ # if we're bootstrapping configure and makefiles:
+ # libxcrypt -> automake -> perl -> libxcrypt
+ #
+ # mitigation:
+ # toolchain@ manually runs `make dist` after running autoconf + `./configure`
+ # and the ebuild uses that.
+ # (Don't include the pre-generated Perl artefacts.)
+ #
+ # solution for future:
+ # Upstream are working on producing `make dist` tarballs.
+ # https://github.com/besser82/libxcrypt/issues/134#issuecomment-871833573
+ #
+ # 2)
+ # configure *unconditionally* needs Perl at build time to generate
+ # a list of enabled algorithms based on the set passed to `configure`:
+ # libxcrypt -> perl -> libxcrypt
+ #
+ # mitigation:
+ # None at the moment.
+ #
+ # solution for future:
+ # Not possible right now. Upstream intend on depending on Perl for further
+ # configuration options.
+ # https://github.com/besser82/libxcrypt/issues/134#issuecomment-871833573
+ #
+ # Therefore, on changes (inc. bumps):
+ # * You must check whether upstream have started providing tarballs with bootstrapped
+ # auto{conf,make};
+ #
+ # * diff the build system changes!
+ #
+ if [[ ${NEED_BOOTSTRAP} == "yes" ]] ; then
+ # Facilitate our split variant build for compat + non-compat
+ eapply "${FILESDIR}"/${PN}-4.4.19-multibuild.patch
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ MULTIBUILD_VARIANTS=(
+ $(usev compat 'xcrypt_compat')
+ xcrypt_nocompat
+ )
+
+ MYPREFIX=${EPREFIX}
+ MYSYSROOT=${ESYSROOT}
+
+ if target_is_not_host; then
+ local CHOST=${CTARGET}
+
+ MYPREFIX=
+ MYSYSROOT=${ESYSROOT}/usr/${CTARGET}
+
+ # Ensure we get compatible libdir
+ unset DEFAULT_ABI MULTILIB_ABIS
+ multilib_env
+ ABI=${DEFAULT_ABI}
+
+ tc-getCC >/dev/null
+ if [[ ${CC} != ${CHOST}-* ]]; then
+ unset CC
+ tc-getCC >/dev/null
+ fi
+
+ strip-unsupported-flags
+ fi
+
+ if use headers-only; then
+ # Nothing is compiled here which would affect the headers for the target.
+ # So forcing CC is sane.
+ local -x CC="$(tc-getBUILD_CC)"
+ fi
+
+ # Avoid possible "illegal instruction" errors with gold
+ # bug #821496
+ tc-ld-disable-gold
+
+ # Doesn't work with LTO: bug #852917.
+ # https://github.com/besser82/libxcrypt/issues/24
+ filter-lto
+
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ if use test; then
+ python_setup
+ fi
+
+ multibuild_foreach_variant multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-werror
+ --prefix="${MYPREFIX}/usr"
+ --libdir="${MYPREFIX}/usr/$(get_libdir)$(usev !system /xcrypt)"
+ --includedir="${MYPREFIX}/usr/include$(usev !system /xcrypt)"
+ --with-pkgconfigdir="${MYPREFIX}/usr/$(get_libdir)/pkgconfig"
+ --with-sysroot="${MYSYSROOT}"
+ )
+
+ tc-export PKG_CONFIG
+
+ case "${MULTIBUILD_ID}" in
+ xcrypt_compat-*)
+ myconf+=(
+ --disable-static
+ --disable-xcrypt-compat-files
+ --enable-obsolete-api=yes
+ )
+ ;;
+ xcrypt_nocompat-*)
+ myconf+=(
+ --enable-obsolete-api=no
+ $(use_enable static-libs static)
+ )
+ ;;
+ *) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
+ esac
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+ use headers-only && return
+
+ multibuild_foreach_variant multilib-minimal_src_compile
+}
+
+multilib_src_test() {
+ emake check
+}
+
+src_test() {
+ multibuild_foreach_variant multilib-minimal_src_test
+}
+
+src_install() {
+ local DESTDIR=${D}
+ if target_is_not_host; then
+ DESTDIR=${ED}/usr/${CTARGET}
+ fi
+
+ multibuild_foreach_variant multilib-minimal_src_install
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if target_is_not_host; then
+ insinto /usr/${CTARGET}/usr/share
+ doins -r "${ED}/usr/share/doc"
+ rm -r "${ED}/usr/share/doc" || die
+ rmdir "${ED}/usr/share" || die
+ fi
+}
+
+multilib_src_install() {
+ if use headers-only; then
+ emake DESTDIR="${DESTDIR}" install-nodist_includeHEADERS
+ else
+ emake DESTDIR="${DESTDIR}" install
+ # Conflicts with sys-apps/man-pages
+ rm "${DESTDIR}${MYPREFIX}"/usr/share/man/man3/crypt{,_r}.3 || die
+ fi
+}
+
+pkg_preinst() {
+ # Verify we're not in a bad case like bug #843209 with broken symlinks.
+ # This can be dropped when, if ever, the split-usr && system && compat case
+ # is cleaned up in *_src_install.
+ local broken_symlinks=()
+ mapfile -d '' broken_symlinks < <(
+ find "${ED}" -xtype l -print0
+ )
+
+ if [[ ${#broken_symlinks[@]} -gt 0 ]]; then
+ eerror "Broken symlinks found before merging!"
+ local symlink target resolved
+ for symlink in "${broken_symlinks[@]}" ; do
+ target="$(readlink "${symlink}")"
+ resolved="$(readlink -f "${symlink}")"
+ eerror " '${symlink}' -> '${target}' (${resolved})"
+ done
+ die "Broken symlinks found! Aborting to avoid damaging system. Please report a bug."
+ fi
+}