summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sys-libs
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin14556 -> 14561 bytes
-rw-r--r--sys-libs/tdb/Manifest3
-rw-r--r--sys-libs/tdb/files/tdb-1.4.7-configure-clang16.patch26
-rw-r--r--sys-libs/tdb/tdb-1.4.7-r1.ebuild (renamed from sys-libs/tdb/tdb-1.4.7.ebuild)8
4 files changed, 34 insertions, 3 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index 4d6621b65b54..64b6ac727379 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index ccea690d5990..77cf3d41afa0 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,3 +1,4 @@
+AUX tdb-1.4.7-configure-clang16.patch 1180 BLAKE2B 6637b19f1f5db53212484b0f91a550932bbc89ae3dd37affc039a166610a15b837ed3f5b7ac898bcb4451186d43625414b812111e3396e10471add7fa5e3a22b SHA512 156f7acb774ae0a6f00ff2bee0817947e256c10b24d55c7f63720bfd52f83e42070a1838c42e20fbb78e73412507db80368165ccdf75b3bb729bc6e5dcbe2223
DIST tdb-1.4.7.tar.gz 741714 BLAKE2B ec2f991bbaa61d46f16b7a68a4e47a2f690cda261dd0e9fd9708e51ad64eefeb54ac8b1102cde6935916f840d3c89d7a2903f58175cceb78ea4ef889e82ddbc6 SHA512 2b5b20c299b60545943f106d854b6e0d4a559e16f08a7ed62fe57ee962bebc888c2e663bd5fef907aace05b316826fe8fbbf3f323b6d3427531e59ffe47d48e4
-EBUILD tdb-1.4.7.ebuild 1514 BLAKE2B 881202c8da5ae32e5c34352615bcf8dbc638ba15a7db02e65573834a10273c98c1941d5e2c683c226b4708ee8df84afb10962f6d95145477fe5424ce40fc725c SHA512 0d0015c90d02dde4a4c78bfa63dac85726661b01b4abdb798d93851348c3f1df7f1abf3c23ce1b14fb79b8cde467fa70349604ee2ae6fede89b8d8b950794d44
+EBUILD tdb-1.4.7-r1.ebuild 1578 BLAKE2B 2cf0ef37d539bdfca581874058d040834303e0a4dc1565b3d8aedc34a1ded480dc8dcaa92d0e00bfcbe525dd1d68d83c22a81087e3c3ae09266f9b9892460832 SHA512 52bcde02dfde90588a343804206e1b35dd0451dc408522a6dcfb71c18f3d6bc2ddc719eb77687ca93f38b0ce38d659c4d40f6c5b2b41835e9168f0ac07e9bc54
MISC metadata.xml 245 BLAKE2B 015a6303c153dcdb4a4b6ec58ea97e6798d3316c6d211559022bd2a26d481356e481ba2ade200171bb182264ce9c132727cf8ce077fba38fabcef92c3431b6ba SHA512 5d1b6ef089165b3325df35b31d33f7c994bbc302399bb47abf3138885f0dd7b04176114de8ffea6ee1ae26a53fc83be9016426714e547fd6405c454b918e39da
diff --git a/sys-libs/tdb/files/tdb-1.4.7-configure-clang16.patch b/sys-libs/tdb/files/tdb-1.4.7-configure-clang16.patch
new file mode 100644
index 000000000000..9d3e485da57c
--- /dev/null
+++ b/sys-libs/tdb/files/tdb-1.4.7-configure-clang16.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/870043
+https://gitlab.com/samba-team/samba/-/merge_requests/2807
+https://src.fedoraproject.org/rpms/libtdb/blob/rawhide/f/libtdb-waf18-c99.patch
+
+Avoid calling lib_func without a prototype.
+
+This commit mirrors the change in commit f4c0a750d4adebcf2342a44e85f04526c34
+("WAF: Fix detection of linker features")
+to buildtools/wafsamba/samba_conftests.py. It fixes the check for rpath
+support with compilers in strict C99 mode.
+
+Submitted upstream: <https://gitlab.com/samba-team/samba/-/merge_requests/2807>
+
+--- a/buildtools/wafsamba/samba_waf18.py
++++ b/buildtools/wafsamba/samba_waf18.py
+@@ -209,7 +209,8 @@ def CHECK_LIBRARY_SUPPORT(conf, rpath=False, version_script=False, msg=None):
+ lib_node.parent.mkdir()
+ lib_node.write('int lib_func(void) { return 42; }\n', 'w')
+ main_node = bld.srcnode.make_node('main.c')
+- main_node.write('int main(void) {return !(lib_func() == 42);}', 'w')
++ main_node.write('int lib_func(void);\n'
++ 'int main(void) {return !(lib_func() == 42);}', 'w')
+ linkflags = []
+ if version_script:
+ script = bld.srcnode.make_node('ldscript')
+
diff --git a/sys-libs/tdb/tdb-1.4.7.ebuild b/sys-libs/tdb/tdb-1.4.7-r1.ebuild
index 395a57071e4e..791b32c1f197 100644
--- a/sys-libs/tdb/tdb-1.4.7.ebuild
+++ b/sys-libs/tdb/tdb-1.4.7-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
@@ -28,6 +28,10 @@ BDEPEND="${PYTHON_DEPS}
WAF_BINARY="${S}/buildtools/bin/waf"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.7-configure-clang16.patch
+)
+
pkg_setup() {
python-single-r1_pkg_setup
export PYTHONHASHSEED=1