summaryrefslogtreecommitdiff
path: root/sys-libs/zlib-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
commitbb5caf02fffada276b5aa598b3b6faea88ca0784 (patch)
treebfa61792a9b53240a85c99f215a14731f74bdd3a /sys-libs/zlib-ng
parent98dd97c6dc5b5b4ad4bb19efeb7f314cc52f43ff (diff)
gentoo auto-resync : 16:06:2023 - 07:40:49
Diffstat (limited to 'sys-libs/zlib-ng')
-rw-r--r--sys-libs/zlib-ng/Manifest3
-rw-r--r--sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch35
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild89
3 files changed, 127 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
index 9faaa101fea9..5ace28f5dac5 100644
--- a/sys-libs/zlib-ng/Manifest
+++ b/sys-libs/zlib-ng/Manifest
@@ -1,3 +1,6 @@
+AUX zlib-ng-2.1.2-cmake.patch 1338 BLAKE2B a082171657f55f792ffba58e05a80df50dcc3dcd145844b5fde79e25e3122666bba5b1a2d2a3fbb6780f02d3fbdfc843d3a8112266e0508c3c890464a7c5c5ac SHA512 c9b317df0c25250ee04df360a4f6095f7476bb3a81d80f10db960003a33aecb843432549395095bb8c904644b40c16477ad51b1fb8842198a5035fdab608947c
DIST zlib-ng-2.0.7.tar.gz 853381 BLAKE2B 89672bd35ee54df72ff995c1b4ed188538011be4cd077e464f21a088b0b70b3f95b4259dc546a65e8d4900dc5bd5bb98041875e361000898b34518f7e008b99b SHA512 1c19a62bb00727ac49049c299fb70060da95b5fafa448144ae4133372ec8c3da15cef6c1303485290f269b23c580696554ca0383dba3e1f9609f65c332981988
+DIST zlib-ng-2.1.2.tar.gz 2404176 BLAKE2B bc0b65520562827b10216110e2020a3341ee0dd853874c19ddb6f9df776fc74a542c1239f77dc3ec2ccb3f92e75f1de7ef104edfecfe37312149b1bc29ae7403 SHA512 2b3073df4eb13d8318f8fa2b7674e4729642488f65dad49d3080ccd830f29e9e3f32a673b42634443ddf9e9ef85cfff4f2f3e182506f950b9ee0a208a92c0465
EBUILD zlib-ng-2.0.7.ebuild 2133 BLAKE2B 9c74f3a169705f9cc1ed010093cfbc316a4209541384534bc51f95435e8242d7e742978ab87d0f2d5ae6d6eb2fe5a00f63364bfd16feb9b840b98b78c03f6cf3 SHA512 c0c0939ad7e58f55607ac01f7186314a1bc7fee8b37c0589e83d1227e5d136c33cfcdd52e82de9fc93f368a6299ecf98778a2d266ceccbe3d26ce2787d6405f9
+EBUILD zlib-ng-2.1.2-r1.ebuild 2447 BLAKE2B edaef6db3a05cc6330db7d771661a0c71c2bb2078381ff243be684928783aaf337646262db8ab49f1e2e246b267ebbf8f7646ad8e83cbe43f8083bb3eb6c9fb1 SHA512 db211f66b6c50095e56efb6b65b6bb07677f08c409e71e2a95b8335fa2605901662fa9d51a2963fd6760a67cd988797e0f10d5702363ea9a635aed03fa52faf5
MISC metadata.xml 431 BLAKE2B 49465a63458ac9b7d807d699d45046fd7dc849796f039956effee297fd4da30109bc6f0644cc46aec680f6a94fb6b839d857b17a2699907fd43317794a12cf78 SHA512 16c8b051776ba1ba37b01eac4127d3a84811b3f4cc9f733480ddd12992bb7119cf3c8a22dc18e4086cf71fe7a16266c21684bc7040070eaf1a8dde1783c8d59e
diff --git a/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch b/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch
new file mode 100644
index 000000000000..8deb07a60515
--- /dev/null
+++ b/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch
@@ -0,0 +1,35 @@
+https://github.com/zlib-ng/zlib-ng/issues/1515
+https://github.com/zlib-ng/zlib-ng/pull/1519
+https://github.com/zlib-ng/zlib-ng/commit/39136c20716a94188c1d041b9656315371d35a47
+
+From 39136c20716a94188c1d041b9656315371d35a47 Mon Sep 17 00:00:00 2001
+From: "Mika T. Lindqvist" <postmaster@raasu.org>
+Date: Sun, 11 Jun 2023 18:38:12 +0300
+Subject: [PATCH] Try to find system copy of googletest before trying to
+ download it. * Don't use system copy if memory sanitizer is enabled
+
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -111,8 +111,6 @@ if(WITH_BENCHMARKS)
+ endif()
+
+ if(WITH_GTEST)
+- include(FetchContent)
+-
+ # Google test requires at least C++11
+ set(CMAKE_CXX_STANDARD 11)
+
+@@ -125,9 +123,13 @@ if(WITH_GTEST)
+ # Must set include and compile options before fetching googletest
+ include_directories($ENV{LLVM_BUILD_DIR}/include $ENV{LLVM_BUILD_DIR}/include/c++/v1)
+ add_compile_options(-stdlib=libc++ -g)
++ elseif(NOT TARGET GTest::GTest)
++ find_package(GTest)
+ endif()
+
+ if(NOT TARGET GTest::GTest)
++ include(FetchContent)
++
+ # Prevent overriding the parent project's compiler/linker settings for Windows
+ set(gtest_force_shared_crt ON CACHE BOOL
+ "Use shared (DLL) run-time lib even when Google Test is built as static lib." FORCE)
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..f96bd980dbf9
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake-multilib
+
+DESCRIPTION="Fork of the zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CPU_USE=(
+ x86_{avx2,avx512f,sse2,ssse3,sse4_2,pclmul}
+ arm_{crc32,neon}
+ ppc_{altivec,vsx2,vsx3}
+)
+IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="compat? ( !sys-libs/zlib )"
+
+PATCHES=(
+ "${FILESDIR}"/zlib-ng-2.1.2-cmake.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT=$(usex compat)
+ -DZLIB_ENABLE_TESTS=$(usex test)
+
+ # Unaligned access is controversial and undefined behaviour
+ # Let's keep it off for now
+ # https://github.com/gentoo/gentoo/pull/17167
+ -DWITH_UNALIGNED=OFF
+ )
+
+ # The intrinsics options are all defined conditionally, so we need
+ # to enable them on/off per-arch here for now.
+ # TODO: There's no s390x USE_EXPAND yet
+ if use amd64 || use x86 ; then
+ mycmakeargs+=(
+ -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
+ -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
+ -DWITH_AVX512VNNI=OFF # TODO, see bug #908556
+ -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
+ -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
+ -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
+ -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
+ -DWITH_VPCLMULQDQ=OFF # TODO, see bug #908556
+ )
+ fi
+
+ if use arm || use arm64 ; then
+ mycmakeargs+=(
+ -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
+ -DWITH_NEON=$(usex cpu_flags_arm_neon)
+ )
+ fi
+
+ if use ppc || use ppc64 ; then
+ # The POWER8 support is VSX which was introduced
+ # VSX2 was introduced with POWER8, so use that as a proxy for it
+ mycmakeargs+=(
+ -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
+ -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
+ -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}