summaryrefslogtreecommitdiff
path: root/sys-libs/zlib-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sys-libs/zlib-ng
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sys-libs/zlib-ng')
-rw-r--r--sys-libs/zlib-ng/Manifest3
-rw-r--r--sys-libs/zlib-ng/metadata.xml14
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild32
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
new file mode 100644
index 000000000000..6756eb8f98c9
--- /dev/null
+++ b/sys-libs/zlib-ng/Manifest
@@ -0,0 +1,3 @@
+DIST zlib-ng-2.0.1.tar.gz 697121 BLAKE2B c4e8c9602f9cf33746c842b2f100adad2fca2b3808691f73ca5b679bbac186a70bf575df731cf60797755275835a5839f4602e08e15faf16b216d4d6d99d4aeb SHA512 c3be0a29e07989353a41a07a4eb037efbc0de5a87f1a4fe338c97c0dc7145225bd1f1039cde4a440be3b54130e297153c5180d69a491b92bc8a69839a8c1a9e3
+EBUILD zlib-ng-2.0.1.ebuild 695 BLAKE2B 738b6ad23488631592fe8c1c0be99eb0d0b2e3963e3edf5c13eb39f2d9bf49322b6806264c0d74e6ccba6407c230d94f9cff6f2d04a296145b4f56985dc29256 SHA512 bd74daaa1d4e4216c79a12a7cb6e0dda502c43dc6e89c0e98c8df6d1e0efa9c2fa21e4632bdc7f7882ba3f4bd185d4abe0b6b39dfa190448c7ce2679713cade5
+MISC metadata.xml 420 BLAKE2B bcd9a2026fb660169b9d56d12c32b78160b18380939b4f44db319605c07c495849fe1cf33f208fd35920dad0aabe3c5d59df7d54685d022a8264d0d31f20bb8f SHA512 344b9daa07f6e11684358928c70b0469058d3d126af49a1be153395686ea87d3a889c9e9d234e44363d7e438dfc321be9d93278e299df0415f3ae8404cfe95e3
diff --git a/sys-libs/zlib-ng/metadata.xml b/sys-libs/zlib-ng/metadata.xml
new file mode 100644
index 000000000000..44db40fcc5ea
--- /dev/null
+++ b/sys-libs/zlib-ng/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<use>
+ <flag name="compat">Enable compatibility to <pkg>sys-libs/zlib</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="github">zlib-ng/zlib-ng</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild b/sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild
new file mode 100644
index 000000000000..6c9d4fdc34fb
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 688f948c5f3067e775bfab5057e8047f467a9ca9 $
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+
+#KEYWORDS="~amd64 ~x86"
+IUSE="compat test"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+ sed "/LIB_INSTALL_DIR/s@/lib\"@/$(get_libdir)\"@" \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT="$(usex compat)"
+ -DZLIB_ENABLE_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}