summaryrefslogtreecommitdiff
path: root/sys-libs/tevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /sys-libs/tevent
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest2
-rw-r--r--sys-libs/tevent/tevent-0.11.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 8cd97db136cd..dba493ee156c 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,3 +1,5 @@
DIST tevent-0.10.2.tar.gz 800731 BLAKE2B 5ea6b83378b04dbe1666432db0dbd4c0df2e6b0bf5ebcc8ec4ec9bdeb834efec75c87b2019dc78c691aba6c4f6467394101febd6010f106046a1fb8848e27405 SHA512 1da8f28898f35daab515892b880d1de601062cc3e2b2570cd62e6913df17b0195a05acb7b484c628cddc0eb8b0cde893105ede3feb32bc5764e7d25684f332ba
+DIST tevent-0.11.0.tar.gz 866327 BLAKE2B 9e6e958597e21c0d228346aa102987f89bb6630a5661cef21b908735469a59e7b4f46bc4473e9c25fe636913a1eebc1f26234448c09739ad812cd3ce97bf5048 SHA512 740346b19bf290ff31b0c1b36e232021b8ad107c3ce27e0e8b1ec1a77485214b07a9b7837ba57f3650a50e4c04f530674e486b5fa4d118a1778259be63b49790
EBUILD tevent-0.10.2.ebuild 1623 BLAKE2B 454a90d64c58f9007774de91e3156791206da74101d3f459ab62c617691d9cc133b03f48d3bcdc8c1849c89669d62cdf650f3591be8271b0b2cb2db15b034290 SHA512 851b32b81404c903406fa697109815d473228d0e0a2e23b24304d24f47822fda5c02959370a98552737e37735ef2c26bc37ff9a8ae9ce6a34e2a90b3ab1308af
+EBUILD tevent-0.11.0.ebuild 1656 BLAKE2B 582f0ec98a19bfe5040afd37b971c0bf767d1070af6376bc1ab16c6d03bf65a91f2d6d504f36935ec219a340534b0897607f2cdf171894e988dc8e8fdd802fc3 SHA512 f411d5d167f65cd63c8e96317bb32b5e12ce33b6373e8279ed506b6dcef7abcacb35dd3182dc556f8a948d9cf90a7e6cffb9c18f0c05af38856b04e01c1f4210
MISC metadata.xml 238 BLAKE2B d8df54241ec3e8c56cd49149dcf4a8eef0eefcd7eacce01bb0f1d5dcdc492b45d25f9388caf582e979dc9eb283ba88b8ab5ee28812072280566b797180eb649e SHA512 f8a66c9ca8ad8a98b25a6f0280652c9262ae5c23cc9cf813bd304722b80e404585689a9b618de7f3d57be64ec28e83d9aa8b84036dcdb2a91117f454b1ef7e93
diff --git a/sys-libs/tevent/tevent-0.11.0.ebuild b/sys-libs/tevent/tevent-0.11.0.ebuild
new file mode 100644
index 000000000000..4539b95bc280
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.11.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="elibc_glibc python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
+ python? (
+ ${PYTHON_DEPS}
+ sys-libs/talloc[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/cmocka-1.1.3
+ elibc_glibc? (
+ net-libs/libtirpc[${MULTILIB_USEDEP}]
+ || (
+ net-libs/rpcsvc-proto
+ <sys-libs/glibc-2.26[rpc(+)]
+ )
+ )
+"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}