summaryrefslogtreecommitdiff
path: root/sys-libs/suacomp/suacomp-0.6.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/suacomp/suacomp-0.6.14.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/suacomp/suacomp-0.6.14.ebuild')
-rw-r--r--sys-libs/suacomp/suacomp-0.6.14.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-libs/suacomp/suacomp-0.6.14.ebuild b/sys-libs/suacomp/suacomp-0.6.14.ebuild
new file mode 100644
index 000000000000..be3cecaf4bfc
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.6.14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
+HOMEPAGE="http://suacomp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+pkg_setup() {
+ if use debug; then
+ append-flags -D_DEBUG -D_DEBUG_TRACE
+ fi
+}
+
+src_prepare() {
+ [[ ${CHOST} == *-interix6* ]] && epatch "${FILESDIR}"/${P}-strtoll.patch
+}
+
+src_compile() {
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}" || die "emake install failed"
+}
+
+src_test() {
+ local v=
+
+ use debug && v="TEST_VERBOSE=1"
+ use debug && export SUACOMP_DEBUG_OUT=stderr
+
+ emake check $(get_opts) ${v} || die "emake check failed"
+}