summaryrefslogtreecommitdiff
path: root/sys-libs/rpmatch-standalone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /sys-libs/rpmatch-standalone
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'sys-libs/rpmatch-standalone')
-rw-r--r--sys-libs/rpmatch-standalone/Manifest3
-rw-r--r--sys-libs/rpmatch-standalone/metadata.xml11
-rw-r--r--sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-libs/rpmatch-standalone/Manifest b/sys-libs/rpmatch-standalone/Manifest
new file mode 100644
index 000000000000..a342e1cf100c
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/Manifest
@@ -0,0 +1,3 @@
+DIST rpmatch-standalone-1.0.tar.gz 3151 BLAKE2B e396d18bfb092aa59c70e81028ba889c1095c97b5f13bffbb4ae7b97a1ce63a6c536663304e4fdefaa06a22854dd5b986ff7238f0091b23bcd336cc6db0fca75 SHA512 9d8fc3be66f23b57793eccf62998d1c0ff8df24d8781d37ee99faf618cdceeda778132df2c75ace2ecd8aa6392bcdf15eaa9ce0acd657401af049ccf61fd5b14
+EBUILD rpmatch-standalone-1.0.ebuild 807 BLAKE2B 1b12d3c301190140ee79ded5e6cb1321ece98bb4358462357123ff1c5337f24e106e967862485bd2939af3e9330d9813bba1666002d59db96972f0f36dc533a8 SHA512 0a9f581b18be40bf695b880dece5e5365cece77e30fb5174d87502f9188f6e71e4c40137f3907290bf5d0d433f7cd4049471d05ce45a2d09159ab441a0c139d4
+MISC metadata.xml 338 BLAKE2B 9e5208f1306450844341cc5c0c69eae9646aeeb3fabdd001e77d848672913ce55d66892e16bb0d811701ee9f3812a57ca68a16687ef15f4b8bddcce7de4d7ed3 SHA512 ef9fe8a5c7f8e299969e6352b588f013c005941aabb0fe1488ce5d6f2a7bcf497ad7e682c1848c684906ded4539db4c83efd66dbca54978519ec65445e041383
diff --git a/sys-libs/rpmatch-standalone/metadata.xml b/sys-libs/rpmatch-standalone/metadata.xml
new file mode 100644
index 000000000000..4aa32e43cbee
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pullmoll/musl-rpmatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
new file mode 100644
index 000000000000..4881a46decc1
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Standalone rpmatch library for use with musl"
+HOMEPAGE="https://github.com/pullmoll/musl-rpmatch"
+SRC_URI="https://github.com/pullmoll/musl-rpmatch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}/musl-rpmatch-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ mkdir "${ED%/}"/usr/$(get_libdir)/pkgconfig/
+ cp "${S}"/musl-rpmatch.pc "${ED%/}"/usr/$(get_libdir)/pkgconfig/rpmatch-standalone.pc
+}