summaryrefslogtreecommitdiff
path: root/sys-libs/readline/readline-4.3_p5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/readline/readline-4.3_p5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/readline/readline-4.3_p5.ebuild')
-rw-r--r--sys-libs/readline/readline-4.3_p5.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-libs/readline/readline-4.3_p5.ebuild b/sys-libs/readline/readline-4.3_p5.ebuild
new file mode 100644
index 000000000000..27cc5342b1bc
--- /dev/null
+++ b/sys-libs/readline/readline-4.3_p5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# This version is just for the ABI .4 library
+
+EAPI="5"
+
+inherit eutils multilib-minimal flag-o-matic
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-4.3-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+patches() {
+ [[ ${PLEVEL} -eq 0 ]] && return 1
+ local opt=$1
+ eval set -- {1..${PLEVEL}}
+ set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
+ if [[ ${opt} == -s ]] ; then
+ echo "${@/#/${DISTDIR}/}"
+ else
+ local u
+ for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
+ printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
+ done
+ fi
+}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
+
+LICENSE="GPL-2"
+SLOT="${PV:0:1}"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+multilib_src_configure() {
+ append-cppflags -D_GNU_SOURCE
+ ECONF_SOURCE=${S} \
+ econf --with-curses --disable-static
+}
+
+multilib_src_compile() {
+ emake -C shlib
+}
+
+multilib_src_install() {
+ emake -C shlib DESTDIR="${D}" install
+ rm -f "${D}"/usr/lib*/*.so
+}