summaryrefslogtreecommitdiff
path: root/sys-libs/pwdb/files/pwdb-0.62-build.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-libs/pwdb/files/pwdb-0.62-build.patch
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-libs/pwdb/files/pwdb-0.62-build.patch')
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-build.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-libs/pwdb/files/pwdb-0.62-build.patch b/sys-libs/pwdb/files/pwdb-0.62-build.patch
index ecef517b1ca3..92c77c28d101 100644
--- a/sys-libs/pwdb/files/pwdb-0.62-build.patch
+++ b/sys-libs/pwdb/files/pwdb-0.62-build.patch
@@ -11,8 +11,8 @@ http://bugs.gentoo.org/126695
http://bugs.gentoo.org/137134
- don't show traditional warnings
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -71,7 +71,7 @@
WARNINGS += -ansi -D_POSIX_SOURCE -Wall -Wwrite-strings \
@@ -22,8 +22,8 @@ http://bugs.gentoo.org/137134
-Wnested-externs -Winline -Wshadow
INCLUDEDIR=-I$(CRTDIR)/include
---- libpwdb/Makefile
-+++ libpwdb/Makefile
+--- a/libpwdb/Makefile
++++ b/libpwdb/Makefile
@@ -50,7 +50,7 @@
@@ -42,8 +42,8 @@ http://bugs.gentoo.org/137134
ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBDYNAME)
$(INSTALL) -m 644 $(LIBSTATIC) $(LIBDIR)
---- libpwdb/posix/pwd.c
-+++ libpwdb/posix/pwd.c
+--- a/libpwdb/posix/pwd.c
++++ b/libpwdb/posix/pwd.c
@@ -7,6 +7,7 @@
*/
@@ -52,8 +52,8 @@ http://bugs.gentoo.org/137134
#define PWDB_HARD_CORE 1
#include <pwdb/pwdb_public.h>
---- libpwdb/posix/undefined.c
-+++ libpwdb/posix/undefined.c
+--- a/libpwdb/posix/undefined.c
++++ b/libpwdb/posix/undefined.c
@@ -5,6 +5,7 @@
*/
@@ -62,8 +62,8 @@ http://bugs.gentoo.org/137134
#define PWDB_HARD_CORE 1
#include <pwdb/pwdb_public.h>
---- libpwdb/pwdb/pwdb_helper.c
-+++ libpwdb/pwdb/pwdb_helper.c
+--- a/libpwdb/pwdb/pwdb_helper.c
++++ b/libpwdb/pwdb/pwdb_helper.c
@@ -18,6 +18,7 @@
*
*/
@@ -72,8 +72,8 @@ http://bugs.gentoo.org/137134
#include "pwdb_public.h"
#include "pwdb_module.h"
---- libpwdb/pwdb/interface/shadow/group.c
-+++ libpwdb/pwdb/interface/shadow/group.c
+--- a/libpwdb/pwdb/interface/shadow/group.c
++++ b/libpwdb/pwdb/interface/shadow/group.c
@@ -533,7 +533,7 @@
static const char *supp_entry[] = {
@@ -83,8 +83,8 @@ http://bugs.gentoo.org/137134
"groups", /* these are serviced by requests */
NULL
};
---- libpwdb/radius/radius.c
-+++ libpwdb/radius/radius.c
+--- a/libpwdb/radius/radius.c
++++ b/libpwdb/radius/radius.c
@@ -145,7 +145,7 @@
const char* password,
RADIUS_RESULT *rad_result)