summaryrefslogtreecommitdiff
path: root/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild')
-rw-r--r--sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild b/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
new file mode 100644
index 000000000000..517f2391cbeb
--- /dev/null
+++ b/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+CMAKE_ECLASS=cmake
+inherit cmake-multilib python-single-r1
+
+DESCRIPTION="A tool to test PAM applications and PAM modules"
+HOMEPAGE="https://cwrap.org/pam_wrapper.html"
+SRC_URI="https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-libs/pam:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local libpam="${EPREFIX}"
+ multilib_is_native_abi || libpam+="/usr"
+ libpam+="/$(get_libdir)/libpam.so.0"
+
+ local mycmakeargs=(
+ -DPAM_LIBRARY="${libpam}"
+ -DUNIT_TESTING=$(usex test)
+ -DPYTHON2_LIBRARY="/dev/null" # Disabled
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_SITELIB="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+}