summaryrefslogtreecommitdiff
path: root/sys-libs/pam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-07 03:59:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-07 03:59:02 +0000
commit632aa90c53a31517c5d2259537aadc192434a332 (patch)
treed466e8c0d3bf25eda998e2f04dc4872de416d117 /sys-libs/pam
parent6bdf113f9fe24f179ee150bada14098e20e87476 (diff)
gentoo auto-resync : 07:02:2024 - 03:59:02
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/Manifest1
-rw-r--r--sys-libs/pam/pam-1.5.3-r1.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index 845831b976f1..ce6ebbbc198a 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -1,5 +1,6 @@
AUX pam-1.5.3-termios.patch 913 BLAKE2B 3fdb9c6320c56fd2c10b76b58700263a1c190dde4a62bb33fdfe2e59e2aebedffe87bd14fb7f02ca9c3df8f9ca21af13a1e5b42cd4eb0b112bb03f311e975288 SHA512 c432af010b188ff8a3f1fb08cc7e68b12651f8a2592fa43c5aec8c60e938c04a62ae67bc0fdb6704df3ec39aa3b40a56c1abbf07e0e5105a7b7ca4af7e44c715
DIST Linux-PAM-1.5.3-docs.tar.xz 466340 BLAKE2B 6bade3c63ebe6b6ca7a86d7385850bb87bf1d6526add3ac5aad140533516c1d27b594a17d09c4127ff985c42e6c571618785d6b2a2913e6575678c4dcf947dc0 SHA512 a9082823da88e0054d74e13aef872519ced5fbef25c8cc1a7e3a99160f835aa09c9ef701b6ec507acd3b540da0019288424bb4c8ebd828181ea90450db1494a9
DIST Linux-PAM-1.5.3.tar.xz 1020076 BLAKE2B 362c939f3afc343e6f4e78e7f6ba6f7a9c6ee0a9948bb5a4fc34cecfd29e9fa974082534d4ceedd04d8d3e34c7b3ef43d2a07ba5f41d26da04ec8330fc3790fb SHA512 af88e8c1b6a9b737ffaffff7dd9ed8eec996d1fbb5804fb76f590bed66d8a1c2c6024a534d7a7b6d18496b300f3d6571a08874cf406cd2e8cea1d5eff49c136a
+EBUILD pam-1.5.3-r1.ebuild 4442 BLAKE2B f0cd9ae58e1c315fb9d9b92ec07cd2f9bde6a4bbd86bbb54920c2b32f659760eea3f3cfc56d6e217dfa6da921a2ebac4b5123d505dfc49bc1bbcae600d8e15f7 SHA512 ad05e3e1cb6f7908499a2d59b35fbcd8f20223c86a28e2c8b0f5c97a433bddc5a0e5e4767e51441bc65f76bf8dbabc167de92c2c0ad75fe6f545dbbd3bb159c7
EBUILD pam-1.5.3.ebuild 4487 BLAKE2B df92ac6e275d0e1b5c881eeca87a10aade04fcfe7f4db37d7da72ace5c878be0858272a5eba57da2237662b674f8e7eb8c810cb2e48c1bf41944dccdddc86b87 SHA512 0fee84d5efab16672b8cbb2eee4802b2d12020ca6b07186f1510f05467dfebfbaf627733fcb67eb2cf04acb5f935ce5ebe26e467e17d349e57b17f8065438272
MISC metadata.xml 846 BLAKE2B e236bd8c7a53097d96164d9063d1dbb9372cef4ec92731dc43df6731cc7f4fc2935aeeb2e069b6da1d4bce3f1cc6a657e0361208581da615f3f41ec72c02261e SHA512 e2e28deadb2c941f8fa31447ec20c95ccb340d638f8b1e742a89ccc2dbb3c8d88e764f750d6e13c5a6320a612d6f2447689c02862a5e897919d1e9bca7857089
diff --git a/sys-libs/pam/pam-1.5.3-r1.ebuild b/sys-libs/pam/pam-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..8f176361a930
--- /dev/null
+++ b/sys-libs/pam/pam-1.5.3-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="Linux-${PN^^}-${PV}"
+
+# Avoid QA warnings
+# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
+TMPFILES_OPTIONAL=1
+
+inherit db-use fcaps flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+HOMEPAGE="https://github.com/linux-pam/linux-pam"
+SRC_URI="
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}.tar.xz
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}-docs.tar.xz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="audit berkdb debug nis selinux"
+
+BDEPEND="
+ app-alternatives/yacc
+ dev-libs/libxslt
+ app-alternatives/lex
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
+ >=virtual/libintl-0-r1[${MULTILIB_USEDEP}]
+ audit? ( >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}] )
+ berkdb? ( >=sys-libs/db-4.8.30-r1:=[${MULTILIB_USEDEP}] )
+ selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
+ nis? (
+ net-libs/libnsl:=[${MULTILIB_USEDEP}]
+ >=net-libs/libtirpc-0.2.4-r2:=[${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}"
+PDEPEND=">=sys-auth/pambase-20200616"
+
+PATCHES=(
+ "${FILESDIR}/${P}-termios.patch"
+)
+
+src_prepare() {
+ default
+ touch ChangeLog || die
+}
+
+multilib_src_configure() {
+ # Do not let user's BROWSER setting mess us up, bug #549684
+ unset BROWSER
+
+ # This whole weird has_version libxcrypt block can go once
+ # musl systems have libxcrypt[system] if we ever make
+ # that mandatory. See bug #867991.
+ if use elibc_musl && ! has_version sys-libs/libxcrypt[system] ; then
+ # Avoid picking up symbol-versioned compat symbol on musl systems
+ export ac_cv_search_crypt_gensalt_rn=no
+
+ # Need to avoid picking up the libxcrypt headers which define
+ # CRYPT_GENSALT_IMPLEMENTS_AUTO_ENTROPY.
+ cp "${ESYSROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+ append-cppflags -I"${T}"
+ fi
+
+ local myconf=(
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ --with-db-uniquename=-$(db_findver sys-libs/db)
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+ --enable-securedir="${EPREFIX}"/$(get_libdir)/security
+ --includedir="${EPREFIX}"/usr/include/security
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-pie
+ --enable-unix
+ --disable-prelude
+ --disable-doc
+ --disable-regenerate-docu
+ --disable-static
+ --disable-Werror
+ # TODO: wire this up now it's more useful as of 1.5.3
+ --disable-econf
+
+ # TODO: add elogind support
+ # lastlog is enabled again for now by us until logind support
+ # is handled. Even then, disabling lastlog will probably need
+ # a news item.
+ --disable-logind
+ --enable-lastlog
+
+ $(use_enable audit)
+ $(use_enable berkdb db)
+ $(use_enable debug)
+ $(use_enable nis)
+ $(use_enable selinux)
+ --enable-isadir='.' # bug #464016
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # tmpfiles.eclass is impossible to use because
+ # there is the pam -> tmpfiles -> systemd -> pam dependency loop
+ dodir /usr/lib/tmpfiles.d
+
+ cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}.conf <<-_EOF_
+ d /run/faillock 0755 root root
+ _EOF_
+ use selinux && cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}-selinux.conf <<-_EOF_
+ d /run/sepermit 0755 root root
+ _EOF_
+
+ local page
+
+ for page in doc/man/*.{3,5,8} modules/*/*.{5,8} ; do
+ doman ${page}
+ done
+}
+
+pkg_postinst() {
+ ewarn "Some software with pre-loaded PAM libraries might experience"
+ ewarn "warnings or failures related to missing symbols and/or versions"
+ ewarn "after any update. While unfortunate this is a limit of the"
+ ewarn "implementation of PAM and the software, and it requires you to"
+ ewarn "restart the software manually after the update."
+ ewarn ""
+ ewarn "You can get a list of such software running a command like"
+ ewarn " lsof / | grep -E -i 'del.*libpam\\.so'"
+ ewarn ""
+ ewarn "Alternatively, simply reboot your system."
+
+ # The pam_unix module needs to check the password of the user which requires
+ # read access to /etc/shadow only.
+ fcaps cap_dac_override sbin/unix_chkpwd
+}