summaryrefslogtreecommitdiff
path: root/sys-libs/openipmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /sys-libs/openipmi
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'sys-libs/openipmi')
-rw-r--r--sys-libs/openipmi/Manifest1
-rw-r--r--sys-libs/openipmi/openipmi-2.0.27-r1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/sys-libs/openipmi/Manifest b/sys-libs/openipmi/Manifest
index 2e161b2e9f66..46d8e8fd2016 100644
--- a/sys-libs/openipmi/Manifest
+++ b/sys-libs/openipmi/Manifest
@@ -7,5 +7,6 @@ DIST OpenIPMI-2.0.26.tar.gz 3124706 BLAKE2B 08afeae1063b404dec3d6f9e5decdf9ac516
DIST OpenIPMI-2.0.27.tar.gz 3125193 BLAKE2B 86639a86803e49393aefbaf5b1d1fee8e2bf399b2772bdee7d07a00d5e6657efe5cdf962cacb0397f9de5deb0b18edc05783c3388f4fc19e1ee2de4c01be0663 SHA512 44aa2eb97559514d61654434f24bf8e87c3f89ea7095fd3d46c1a889e16c128f29ca19cfb9747afc7fd432ada84406ee884bc8b9c65e28b8bd033d368b744fe3
EBUILD openipmi-2.0.22.ebuild 2758 BLAKE2B 2e9d3b059b62cbfefc31fc0c941f5975c705a6b849014a47f26b7b4a7880114405e7ffda9422ae9dd948f7ad6d6aa5b18c12a9e404e7dc2c204a9089982f5ae1 SHA512 68bef9639ea0d72e20ef4b4c1d0d59307c20c70c702160f90c975daeae5a4ddeddfce7123defde623d7df4fd278eff8a53b501c76c210cf056d3bba975c1ad01
EBUILD openipmi-2.0.26.ebuild 2538 BLAKE2B e560fa3ca1c38da676199f3eda29f5dab8adb037fa3b5b717dbe67e2b8af36a2daf3a737267df9b7db38e8bc792032924c58eb8d458164d3704b0a9a54b36a66 SHA512 aab2dae8346b88c4ffefa34ee5215269bf621d8106c804c33f5c659d410802e4556f12a2e3de394a66477ac3c9d967534c00878999e04dec5503a8e8fad16571
+EBUILD openipmi-2.0.27-r1.ebuild 2332 BLAKE2B 0ad93c44fbf3c9185baa92b7d43ec2a5069f224876ced6b046e8042a7161ae24c461a704dd8b1aecad6ce676c04e07321a5c6cda9879030033e07a2d0fb31059 SHA512 ca518080b08e339141edff29c2a4d551063e5c23c6df7df019e7158fc572439058fbc8c8b3a8d9ef93fd797cae646f2a2514f0e91d98751c351dfe2df76d68c8
EBUILD openipmi-2.0.27.ebuild 2574 BLAKE2B bdda42ac93e50ce16240a2d51ca512f99c8fa5f4d565f0b3be9e1267c368639ae59627f955f185f6c1b5500e903badb19d3ea61ec1f59d9a21d93b90acbd9d66 SHA512 bba8e7809f15d28e4ebdb802165b9e04256b14bc5ab82fe6f063fd7c129599a1f1177b4772547700b4c0978735db5d01eeb88cb656596b2377cc3e4ed9486593
MISC metadata.xml 347 BLAKE2B 4857bbfde0e588b4ad2ac893f826affe46d77ead16c7565fa775580c23fdd35df745a9050b599d0ff333290a155b48cf6d571065abd8b2fe5cc4b2e136f3efc1 SHA512 f67b97714b2b543109c2bc90d8f474df13e8915b7a14fdc3a16b62f1dfbc59ac27c8e64d19429b87a63ee2c1e4812cee26d8fb797591028484b2072b1951231f
diff --git a/sys-libs/openipmi/openipmi-2.0.27-r1.ebuild b/sys-libs/openipmi/openipmi-2.0.27-r1.ebuild
new file mode 100644
index 000000000000..e4bc46a974e6
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-2.0.27-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="https://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV/_/-}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl python static-libs tcl"
+S="${WORKDIR}/${MY_P}"
+RESTRICT='test'
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/gdbm:=
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ crypt? ( dev-libs/openssl:0= )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.21"
+BDEPEND="virtual/pkgconfig"
+
+# Gui is broken!
+# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.26-tinfo.patch" #501510
+
+ "${FILESDIR}/${PN}-2.0.26-readline.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Bug #298250: parallel install fix.
+ sed -r -i \
+ -e '/^install-data-local:/s,$, install-exec-am,g' \
+ cmdlang/Makefile.{am,in} || die
+
+ # We touch the .in and .am above because if we use the below, the Perl stuff
+ # is very fragile, and often fails to link.
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ # these binaries are for root!
+ --bindir="${EPREFIX}"/usr/sbin
+ --with-glib
+ --with-glibver=2.0
+ --with-swig
+ --without-tkinter
+ $(use_with snmp ucdsnmp yes)
+ $(use_with crypt openssl yes)
+ $(use_with perl perl yes)
+ $(use_with tcl tcl yes)
+ $(use_with python python yes)
+ )
+
+ # GUI is broken
+ #use tk && use python && use !tcl && \
+ # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+ #if use python && use tcl; then
+ # myconf+=( $(use_with tk tkinter) )
+ #else
+ # myconf+=( --without-tkinter )
+ #fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
+ newdoc cmdlang/README README.cmdlang
+
+ use python && python_optimize
+
+ find "${ED}" -name "*.la" -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}