summaryrefslogtreecommitdiff
path: root/sys-libs/minizip-ng/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
commitc5572b13d51970d6603acd131f27991cc1b66a79 (patch)
tree459c832fa5c0913b9ce0f85eed5e29922cc0425f /sys-libs/minizip-ng/files
parent6e476156e1a0d2f4aa53968c37835c3441301367 (diff)
gentoo auto-resync : 19:11:2022 - 07:00:00
Diffstat (limited to 'sys-libs/minizip-ng/files')
-rw-r--r--sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch b/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch
new file mode 100644
index 000000000000..57197d0da587
--- /dev/null
+++ b/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch
@@ -0,0 +1,25 @@
+https://github.com/zlib-ng/minizip-ng/pull/657
+
+From 3aa42e0520e4e7ffeae5a3def458c7ee0fefacb9 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 19 Nov 2022 03:09:34 +0000
+Subject: [PATCH] Search system for GTest before downloading. #654
+
+Distributions often do builds with no network access available
+for both security reasons and also to ensure reproducibility.
+
+This change tells CMake to query the system for a copy of gtest,
+but if it's not available, it'll fall back to downloading via
+FetchContent.
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -2,6 +2,8 @@ cmake_minimum_required(VERSION 3.12)
+
+ include(FetchContent)
+
++find_package(GTest)
++
+ enable_language(CXX)
+
+ if(NOT TARGET GTest::GTest)
+