summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /sys-libs/llvm-libunwind
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/Manifest1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/Manifest b/sys-libs/llvm-libunwind/Manifest
index 2ebeec406a9c..9d5b59724dbb 100644
--- a/sys-libs/llvm-libunwind/Manifest
+++ b/sys-libs/llvm-libunwind/Manifest
@@ -12,5 +12,6 @@ EBUILD llvm-libunwind-3.9.1.ebuild 1187 BLAKE2B adc3bdff94f0b5a855c4d6eac0ee123d
EBUILD llvm-libunwind-4.0.1.ebuild 1094 BLAKE2B dec5d0847983833e461635ac5711b5d253963650aed87678277bec86d1334ae9348d26605e20acf2a8d2405e891dd10c9303abf7d243ed86e36c8f3e3f12b83b SHA512 3fb7283eea0b4282c549d7cf2cee1aea0f9d28b7689f5b83a32893c32ebfabc703eb0328593109db96a86351b639bc3e60572c7de93fbed18dd359a14b352386
EBUILD llvm-libunwind-5.0.0.ebuild 1096 BLAKE2B 50a0cc37e419efa13bdb883d11922dc51b094d09b8fb758e9f8e5b5b0bc17bc17cf2ecb3384691e11ee54b8e813cb5a95afcd4e34c364dc6221ac8a5a8ef3ca8 SHA512 8ff88efcf19f55a6880f4fba24126645b6429eb667ea8cdd90aaa800ec856f1f83c2ce2ebfc4a8074ee25af2f68ddc67216e1a1423cbc2f744accf0a075bbcb6
EBUILD llvm-libunwind-5.0.1.ebuild 1096 BLAKE2B 50a0cc37e419efa13bdb883d11922dc51b094d09b8fb758e9f8e5b5b0bc17bc17cf2ecb3384691e11ee54b8e813cb5a95afcd4e34c364dc6221ac8a5a8ef3ca8 SHA512 8ff88efcf19f55a6880f4fba24126645b6429eb667ea8cdd90aaa800ec856f1f83c2ce2ebfc4a8074ee25af2f68ddc67216e1a1423cbc2f744accf0a075bbcb6
+EBUILD llvm-libunwind-6.0.9999.ebuild 1109 BLAKE2B 9d9760e4296c970b416c237ea5203751a4a17ff94f744779378c986b0315b36ac0a52c317d8f9da75ce314de8fa7cd0380cbeb2c1d9daa16f75dc483c690b8e8 SHA512 6ec698db9f52b427b9bd5bb16fbcb825488a2fcc0b010c45fcecffe522b0b5842ae1b9653a2e45bddfd89ed5d001e554649636fe1fc019cb64b5ac4575f80b01
EBUILD llvm-libunwind-9999.ebuild 1084 BLAKE2B 549f50753c3ed20954b1fd1260ce1cd216a4e9bf56c23b59e8ac34b9e8163419a76c3634995143fbea2c8f681069944607c823f130235b97985936e1030a4413 SHA512 9393e7fafe3a5b0416c0206a1d25ba9f0601dfc329293c9d4b02d61859aaf7f5b1c1be1fc7e82429f278385f70890f1ab49b8db0785c33ac0d2e193877741cd7
MISC metadata.xml 302 BLAKE2B 1cdee7813ed9a3766b2eddccd14f9e0576ba5cc7f812d7af4f35c8c2e5991790f3800c6473c37da90d72804832fd9af969a2e3bf7aa625f0d3a32da1dbcefacf SHA512 3afaef82e6a495a81e221524ae7604dc170ef5c103333728674faf0417c45ba7996118c10466eaa24f8feef9ed8f0fc60d535a5195462317d61c61a531c8a285
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
new file mode 100644
index 000000000000..6c50f73f19b4
--- /dev/null
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+inherit cmake-multilib git-r3 llvm
+
+DESCRIPTION="C++ runtime stack unwinder from LLVM"
+HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/libunwind.git
+ https://github.com/llvm-mirror/libunwind.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +static-libs"
+
+RDEPEND="!sys-libs/libunwind"
+# LLVM 4 required for llvm-config --cmakedir
+DEPEND=">=sys-devel/llvm-4"
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
+ -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}