summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild28
1 files changed, 5 insertions, 23 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild
index 68e91d4eeac9..373f7d8c03ae 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.ebuild
@@ -3,23 +3,14 @@
EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-multilib llvm multiprocessing python-any-r1
-
-MY_P=libunwind-${PV/_/}.src
-LIBCXX_P=libcxx-${PV/_/}.src
-LIBCXXABI_P=libcxxabi-${PV/_/}.src
+inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz
- test? (
- https://releases.llvm.org/${PV}/${LIBCXX_P}.tar.xz
- https://releases.llvm.org/${PV}/${LIBCXXABI_P}.tar.xz )"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( libunwind )
+LLVM_TEST_COMPONENTS=( libcxx{,abi} )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -46,15 +37,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_unpack() {
- default
-
- if use test; then
- mv "${LIBCXX_P}" libcxx || die
- mv "${LIBCXXABI_P}" libcxxabi || die
- fi
-}
-
multilib_src_configure() {
local libdir=$(get_libdir)
@@ -77,7 +59,7 @@ multilib_src_configure() {
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
- -DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
+ -DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
)
fi