summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild
deleted file mode 100644
index 22e26e7dbe57..000000000000
--- a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib llvm
-
-DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
-SRC_URI="https://releases.llvm.org/${PV/_//}/libunwind-${PV/_/}.src.tar.xz"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="debug +static-libs"
-
-RDEPEND="!sys-libs/libunwind"
-# LLVM 4 required for llvm-config --cmakedir
-DEPEND=">=sys-devel/llvm-4"
-
-S=${WORKDIR}/libunwind-${PV/_/}.src
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-multilib_src_configure() {
- local libdir=$(get_libdir)
-
- local mycmakeargs=(
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
- -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- # install headers like sys-libs/libunwind
- doheader "${S}"/include/*.h
-}