summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
commitd0041c590ed45bbfeae458ea926e36bc64e41dd7 (patch)
tree9f8a3bcf226736635a558a6d70fcd46b60f90a17 /sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
parent5067796b074450a155155c782ef4885c885cfb2b (diff)
gentoo auto-resync : 10:09:2023 - 16:36:07
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
index 43f8868fc308..94ec81df1452 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"