summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-07 19:24:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-07 19:24:36 +0100
commit7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (patch)
treec9aa002e33c61cd30a2a1615be86cd9961239b0b /sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
parent27a61babf89122aeb64d52f4ea8f6f068b928da4 (diff)
gentoo auto-resync : 07:10:2022 - 19:24:35
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
index 67d11a24dc77..b53a48502232 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
@@ -20,13 +20,12 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAJOR}
"
BDEPEND="
clang? (
- sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
@@ -46,7 +45,7 @@ python_check_deps() {
}
pkg_setup() {
- llvm_pkg_setup
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}