summaryrefslogtreecommitdiff
path: root/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
commitca144cbf71b2faf598564847378fa40a0090d67c (patch)
treed9dc05cd474f9feb1649b145b41e453bbebc1ad4 /sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
parent7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (diff)
gentoo auto-resync : 15:10:2022 - 19:51:12
Diffstat (limited to 'sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
index c55c58c004b0..7c7340f29a7b 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
@@ -165,6 +165,7 @@ get_xcpkgconfigdir() {
multilib_src_configure() {
local -a myconf=(
+ --host=${CTARGET}
--disable-werror
--libdir=$(get_xclibdir)
--with-pkgconfigdir=$(get_xcpkgconfigdir)
@@ -196,6 +197,16 @@ multilib_src_configure() {
*) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
esac
+ tc-export PKG_CONFIG
+
+ if is_cross; then
+ if tc-is-clang; then
+ export CC="${CTARGET}-clang"
+ else
+ export CC="${CTARGET}-gcc"
+ fi
+ fi
+
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}