summaryrefslogtreecommitdiff
path: root/sys-libs/libunwind/libunwind-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 09:50:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 09:50:45 +0100
commit3d00647fec2600e217d690a64ba45a41f1a2fa0c (patch)
tree372903cfdc422592f1c2b4df752276358d1e7984 /sys-libs/libunwind/libunwind-1.6.2.ebuild
parente0b23919d82070530276a893043523d8084be1e8 (diff)
gentoo auto-resync : 10:06:2023 - 09:50:45
Diffstat (limited to 'sys-libs/libunwind/libunwind-1.6.2.ebuild')
-rw-r--r--sys-libs/libunwind/libunwind-1.6.2.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/sys-libs/libunwind/libunwind-1.6.2.ebuild b/sys-libs/libunwind/libunwind-1.6.2.ebuild
deleted file mode 100644
index 3c8d7610772f..000000000000
--- a/sys-libs/libunwind/libunwind-1.6.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 2005-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-inherit multilib-minimal
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0/8" # libunwind.so.8
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 -sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame doc libatomic lzma static-libs test zlib"
-
-RESTRICT="test !test? ( test )" # some tests are broken (toolchain version dependent, rely on external binaries)
-
-# We just use the header from libatomic.
-RDEPEND="
- lzma? ( app-arch/xz-utils[static-libs?,${MULTILIB_USEDEP}] )
- zlib? ( sys-libs/zlib[static-libs?,${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/libunwind.h
-
- # see libunwind.h for the full list of arch-specific headers
- /usr/include/libunwind-aarch64.h
- /usr/include/libunwind-arm.h
- /usr/include/libunwind-hppa.h
- /usr/include/libunwind-ia64.h
- /usr/include/libunwind-mips.h
- /usr/include/libunwind-ppc32.h
- /usr/include/libunwind-ppc64.h
- /usr/include/libunwind-riscv.h
- /usr/include/libunwind-sh.h
- /usr/include/libunwind-tilegx.h
- /usr/include/libunwind-x86.h
- /usr/include/libunwind-x86_64.h
-)
-
-src_prepare() {
- default
-
- chmod +x src/ia64/mk_cursor_i || die
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- # --enable-cxx-exceptions: always enable it, headers provide the interface
- # and on some archs it is disabled by default causing a mismatch between the
- # API and the ABI, bug #418253
- --enable-cxx-exceptions
- --enable-coredump
- --enable-ptrace
- --enable-setjmp
- $(use_enable debug-frame)
- $(use_enable doc documentation)
- $(use_enable lzma minidebuginfo)
- $(use_enable static-libs static)
- $(use_enable zlib zlibdebuginfo)
- # conservative-checks: validate memory addresses before use; as of 1.0.1,
- # only x86_64 supports this, yet may be useful for debugging, couple it with
- # debug useflag.
- $(use_enable debug conservative_checks)
- $(use_enable debug)
- $(use_enable test tests)
- )
-
- export ac_cv_header_atomic_ops_h=$(usex libatomic)
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- # bug #586208
- CCACHE_NODIRECT=1 default
-}
-
-multilib_src_test() {
- # Explicitly allow parallel build of tests.
- # Sandbox causes some tests to freak out.
- SANDBOX_ON=0 emake check
-}
-
-multilib_src_install_all() {
- find "${ED}" -name "*.la" -type f -delete || die
-}