summaryrefslogtreecommitdiff
path: root/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 16:40:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 16:40:34 +0100
commit9257212a8841f37588d5b5a94a7930db4585a106 (patch)
tree8ee63d1ea86eee544e495fadca1e7f0a5280b816 /sys-libs/libsmbios/libsmbios-2.4.3.ebuild
parentb426a5cef3f0ebe3389686a1c145a834d3a1e120 (diff)
gentoo auto-resync : 09:09:2022 - 16:40:34
Diffstat (limited to 'sys-libs/libsmbios/libsmbios-2.4.3.ebuild')
-rw-r--r--sys-libs/libsmbios/libsmbios-2.4.3.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
index 1a480d6268b6..15ae620a9e16 100644
--- a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit autotools flag-o-matic python-single-r1
@@ -14,7 +14,8 @@ LICENSE="|| ( GPL-2+ OSL-2.1 ) BSD Boost-1.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ia64 ~riscv x86"
IUSE="doc graphviz nls +python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -26,8 +27,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )
graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
+ nls? ( sys-devel/gettext )"
+BDEPEND="test? (
+ ${PYTHON_DEPS}
+ >=dev-util/cppunit-1.9.6
+)"
PATCHES=(
"${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
@@ -36,7 +40,9 @@ PATCHES=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ if use python || use test; then
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {
@@ -45,7 +51,9 @@ src_prepare() {
# Don't build yum-plugin - we don't need it
sed '/yum-plugin/d' -i Makefile.am || die
- python_fix_shebang src/pyunit/test*.py
+ if use test; then
+ python_fix_shebang src/pyunit/test*.py
+ fi
eautoreconf
}
@@ -67,7 +75,7 @@ src_configure() {
src_install() {
emake install DESTDIR="${D}"
- if use python ; then
+ if use python; then
python_scriptinto /usr/sbin
python_doscript "${ED}"/usr/sbin/smbios-{{battery,keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
fi