summaryrefslogtreecommitdiff
path: root/sys-libs/libseccomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /sys-libs/libseccomp
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/Manifest2
-rw-r--r--sys-libs/libseccomp/libseccomp-2.4.2.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/Manifest b/sys-libs/libseccomp/Manifest
index 4e864e53eaf7..0e1110ceb355 100644
--- a/sys-libs/libseccomp/Manifest
+++ b/sys-libs/libseccomp/Manifest
@@ -1,5 +1,7 @@
DIST libseccomp-2.4.0.tar.gz 604987 BLAKE2B 2dd84f2c08d40a61dfe4fdc47a9dcdad2701e2918cdcdeae2d15a66eb114221866121bab11a8292f3bd31493b6cd7b370d0728976cb1bbfd0dbb9e32127b9045 SHA512 daa4a32c6c2b2f39aa9db1a4606619f9faeffcd2fca00c25ac5cf95d0405639ec21203293be7c8341317a05b18fd9f603a201544457cac91bf034a0bbd4dfc88
DIST libseccomp-2.4.1.tar.gz 606860 BLAKE2B f80f11ef4e03fc9f59fdd38466e32b081e9858473266942b22a1bd1afbd480d21e9c72f9c33e197349fcd2658361f84ee1ee371f73aa5dfe19561472fec8c1ed SHA512 1fe47ebb032635ba1b1cbefb505a0c103bae659844d1bf106d03e7f28b3c470726f7b0dbbe76d10ab89501630dc4f20b162c2eeefa22394eb632f803ae62ccc5
+DIST libseccomp-2.4.2.tar.gz 601014 BLAKE2B cff2612498a6ff3097809e9e04542e0be12c2c5d80fd51c2abd35fb6ac59f3ef7fce1c5205216876c1f67eb762d31c7df8e0f237f3957b7710148a1298502ae5 SHA512 375a3c7c658be6a08b9bb30963e10bb49e8e066119e0be6d3d97faac3db18b8e2c6938d8b5d3874b2f5331ec8295170112fbae83b5a3b5a5bebc0d6705bdfdbb
EBUILD libseccomp-2.4.0.ebuild 1021 BLAKE2B 074c5338a42ab2fc31182d94dc3268e10348c97c4aa1cb42139b926dddead8f7c630b0481f24b42ada7160215611b4238f4d64ab9c2fa9ea7908ff01edff4606 SHA512 7d97edbe6d0248cf1339381e5e6f24478cf38f7c48781c36f143dd78a607918c1c35e14cc9d206e405872d05bdeae9d4f0881151031738a249c7863e878da10b
EBUILD libseccomp-2.4.1.ebuild 1028 BLAKE2B e5bb28b41e63a74c7a51fbd9bddc65a6cd2ea558ac0d32381862c62ba3554150311718d5f9aa83c95d6aefc551e29c085b885007f49e25597f02411808818ea4 SHA512 0a59b16b9056a1d16be91ef066ba17958465d7cc5646e2bf5de54ccbee74bb5ffc88b9fddc1557c385ff1fe58947a0347b8b5e8eff643917d9bb9933478f344a
+EBUILD libseccomp-2.4.2.ebuild 1036 BLAKE2B 31956c980efc78d261610bc2ab63c67612e54a6d70e0db083b08a613d073c59bbd3c9b1e623dd8948152407c5f682968a0fe30c0bc2cff7903f1afcb2182db13 SHA512 4c1e2080ed599e98f66dd068aa8028e4fd5fdf0e678ab06deb3f8c6a086108c898eaa3915299365a59197c0509c687cab702e24564e12f69c0b0208b1668fb03
MISC metadata.xml 395 BLAKE2B a375d336aa4cdc973bc6edefa50745bdc67753e53988718a804b9dfab02d8c8324fd998c9c17dfac0f1c57a7068d2c036ad37194a46c3aec208314171c357367 SHA512 db1f67e65f149ce7122b9c845d1305cdca95428267590d7261af489493dd34518c178ce8ce402bea290c0ee441fdece5006c62803ed587281dc7d84a25a3c3e4
diff --git a/sys-libs/libseccomp/libseccomp-2.4.2.ebuild b/sys-libs/libseccomp/libseccomp-2.4.2.ebuild
new file mode 100644
index 000000000000..6fc6a1ee79ec
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-python
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name libseccomp.la -delete
+ einstalldocs
+}