summaryrefslogtreecommitdiff
path: root/sys-libs/librtas/librtas-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 05:23:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 05:23:06 +0100
commit295483480d7b8ba2fff987fdd32eaa36fe730ce4 (patch)
treeaec8cd0bd370cff7ad62445d484b1dcea5e8dab6 /sys-libs/librtas/librtas-2.0.3.ebuild
parent4ae4e74a3a13c7c5aaebf61e650538b005204fcb (diff)
gentoo auto-resync : 20:09:2022 - 05:23:06
Diffstat (limited to 'sys-libs/librtas/librtas-2.0.3.ebuild')
-rw-r--r--sys-libs/librtas/librtas-2.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-libs/librtas/librtas-2.0.3.ebuild b/sys-libs/librtas/librtas-2.0.3.ebuild
new file mode 100644
index 000000000000..6af4142321e4
--- /dev/null
+++ b/sys-libs/librtas/librtas-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="A set of libraries for userspace access to RTAS on the PowerPC platform(s)"
+HOMEPAGE="https://github.com/ibm-power-utilities/librtas"
+SRC_URI="https://github.com/ibm-power-utilities/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~ppc64-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install docdir="${EPREFIX}"/usr/share/doc/${PF}
+ find "${D}" -name '*.la' -delete || die
+ # librtas_src/syscall_rmo.c: static const char *lockfile_path = "/var/lock/LCK..librtas";
+ # this way we prevent sandbox violations in lscpu linked to rtas
+ dodir /etc/sandbox.d
+ echo 'SANDBOX_PREDICT="/run/lock/LCK..librtas"' > "${ED}"/etc/sandbox.d/50librtas || die
+}