summaryrefslogtreecommitdiff
path: root/sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild')
-rw-r--r--sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild b/sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..72f37fa8b677
--- /dev/null
+++ b/sys-libs/libraw1394/libraw1394-2.1.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Library that provides direct access to the IEEE 1394 bus"
+HOMEPAGE="https://ieee1394.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -type f -delete || die
+}