summaryrefslogtreecommitdiff
path: root/sys-libs/libosinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sys-libs/libosinfo
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sys-libs/libosinfo')
-rw-r--r--sys-libs/libosinfo/Manifest2
-rw-r--r--sys-libs/libosinfo/libosinfo-1.9.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/Manifest b/sys-libs/libosinfo/Manifest
index 1cc5e804aade..a1540dfee604 100644
--- a/sys-libs/libosinfo/Manifest
+++ b/sys-libs/libosinfo/Manifest
@@ -1,3 +1,5 @@
DIST libosinfo-1.8.0.tar.xz 273324 BLAKE2B 0d289df4eb1eb0f9793227b7925cfc37e253a4db0da5c420e7b058d4c060ae50a5609bd25f7d07822e0110e535561f675cf8eddbe6bce0875757f10ee30b2c22 SHA512 1d831443af9eea6a5ba1edccafcd47e56fc55e3cc43c0572044abc9c70c4eb8bbe0d95019d42bbdc3b680a2f52511863412ea9587c6eb553353b3802e94b2960
+DIST libosinfo-1.9.0.tar.xz 279376 BLAKE2B 9f231f022d80e96fc9b031ff8f16ea1e432e5e3ce079e384ad123043b89dd5e47ae119aec3052c8926965bf30c49b150f0ee727fb3b0e0391d393b1031aabeab SHA512 2e62e69f4353eb935734f091caa4cc4e3dce74020a93b684807470f068da73e8ecb7f4af0623b6d3053ecff3a34c6709a783dec3d25a56dc69f0e7ff9041cf26
EBUILD libosinfo-1.8.0-r1.ebuild 1517 BLAKE2B dddb734dbb4428417fa830d31f9e1bbc8f165d5d8a6d03ff8e929b3025a8106b1e7a2db2cc4191bbba2e0b77da85768a54a70fb85480569d9a2f772f63e4cc67 SHA512 541d1a76d09bd950909f4b754286095d48af5614e3552d56316272f846d8a5eefc5c8c5fa68d210be69f0c31fc3dfde226097b5dc747e378efef86e52c48d642
+EBUILD libosinfo-1.9.0.ebuild 1520 BLAKE2B b04063d0559ff79ae8c779afe4a9f3a745b28ba8ccb0e363228dddc5b99187559386a46f129dde7facb882a16f1339d8fb547135203131cb998a8ee0f422ab62 SHA512 619dbe2412b7dc5bb3b8a6fbfbe243e631c6e91cd8839b61a20d85061dd4fec518d5697534d03af54f92b735f3092abb6b8bdf408b51350dbabc436bceda9fff
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/sys-libs/libosinfo/libosinfo-1.9.0.ebuild b/sys-libs/libosinfo/libosinfo-1.9.0.ebuild
new file mode 100644
index 000000000000..b019a119ace7
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-1.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit meson udev vala xdg
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="gtk-doc +introspection +vala test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Unsure about osinfo-db-tools rdep, but at least fedora does it too
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ net-libs/libsoup:2.4
+ >=dev-libs/libxml2-2.6.0
+ >=dev-libs/libxslt-1.0.0
+ sys-apps/hwids[pci,usb]
+ sys-apps/osinfo-db-tools
+ sys-apps/osinfo-db
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+"
+DEPEND="${RDEPEND}"
+# perl dep is for pod2man for automagic manpage building
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.10
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ xdg_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_feature introspection enable-introspection)
+ $(meson_use test enable-tests)
+ $(meson_feature vala enable-vala)
+ -Dwith-pci-ids-path=/usr/share/misc/pci.ids
+ -Dwith-usb-ids-path=/usr/share/misc/usb.ids
+ )
+ meson_src_configure
+}