summaryrefslogtreecommitdiff
path: root/sys-libs/libomp/libomp-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /sys-libs/libomp/libomp-5.0.1.ebuild
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'sys-libs/libomp/libomp-5.0.1.ebuild')
-rw-r--r--sys-libs/libomp/libomp-5.0.1.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/sys-libs/libomp/libomp-5.0.1.ebuild b/sys-libs/libomp/libomp-5.0.1.ebuild
index 9075688c9e49..6c5b2b9c352c 100644
--- a/sys-libs/libomp/libomp-5.0.1.ebuild
+++ b/sys-libs/libomp/libomp-5.0.1.ebuild
@@ -20,8 +20,8 @@ SRC_URI="https://releases.llvm.org/${PV/_//}/openmp-${PV/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-IUSE="hwloc ompt test"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="hwloc kernel_linux ompt test"
RESTRICT="!test? ( test )"
RDEPEND="hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )"
@@ -42,22 +42,28 @@ S=${WORKDIR}/openmp-${PV/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-CONFIG_CHECK="~!SCHED_PDS"
-ERROR_SCHED_PDS="PDS scheduler versions >= 0.98c < 0.98i (e.g. used in kernels
->= 4.13-pf11, no fixed release yet) do not implement sched_yield() call which
-may result in horrible performance problems with libomp. If you are using one
-of the specified kernel versions, you may want to disable the PDS scheduler."
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+kernel_pds_check() {
+ if use kernel_linux && kernel_is -lt 4 15 && kernel_is -ge 4 13; then
+ local CONFIG_CHECK="~!SCHED_PDS"
+ local ERROR_SCHED_PDS="\
+PDS scheduler versions >= 0.98c < 0.98i (e.g. used in kernels >= 4.13-pf11
+< 4.14-pf9) do not implement sched_yield() call which may result in horrible
+performance problems with libomp. If you are using one of the specified
+kernel versions, you may want to disable the PDS scheduler."
+
+ check_extra_config
+ fi
+}
+
pkg_pretend() {
- linux-info_pkg_setup
+ kernel_pds_check
}
pkg_setup() {
- linux-info_pkg_setup
use test && python-any-r1_pkg_setup
}