summaryrefslogtreecommitdiff
path: root/sys-libs/libomp/libomp-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sys-libs/libomp/libomp-11.0.0.9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sys-libs/libomp/libomp-11.0.0.9999.ebuild')
-rw-r--r--sys-libs/libomp/libomp-11.0.0.9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/libomp/libomp-11.0.0.9999.ebuild b/sys-libs/libomp/libomp-11.0.0.9999.ebuild
index aa0be13c4ba5..01e5f189d659 100644
--- a/sys-libs/libomp/libomp-11.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-11.0.0.9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
@@ -32,7 +33,7 @@ RDEPEND="
# - sys-devel/clang provides the compiler to run tests
DEPEND="${RDEPEND}"
BDEPEND="dev-lang/perl
- offload? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+ offload? ( virtual/pkgconfig )
test? (
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
>=sys-devel/clang-6
@@ -66,6 +67,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake_src_prepare
+}
+
multilib_src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs=(
@@ -95,12 +103,12 @@ multilib_src_configure() {
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-libomp
+ cmake_build check-libomp
}