summaryrefslogtreecommitdiff
path: root/sys-libs/libhx/libhx-3.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-libs/libhx/libhx-3.25.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-libs/libhx/libhx-3.25.ebuild')
-rw-r--r--sys-libs/libhx/libhx-3.25.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-3.25.ebuild b/sys-libs/libhx/libhx-3.25.ebuild
new file mode 100644
index 000000000000..5f6d32a514e4
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.25.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="https://inai.de/projects/libhx/"
+SRC_URI="https://inai.de/files/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/32" # soname version
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.22-no-lyx.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ dodoc doc/changelog.txt
+ rm "${ED}/usr/share/doc/${PF}/"*.pdf || die
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}