summaryrefslogtreecommitdiff
path: root/sys-libs/libhx/libhx-3.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/libhx/libhx-3.22.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/libhx/libhx-3.22.ebuild')
-rw-r--r--sys-libs/libhx/libhx-3.22.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-3.22.ebuild b/sys-libs/libhx/libhx-3.22.ebuild
new file mode 100644
index 000000000000..2790a6dacad8
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.22.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="http://libhx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default
+ dodoc doc/*.txt
+ prune_libtool_files --all
+}