summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 11:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 11:25:44 +0100
commit944021dc3fb629a9c074228bf7da9f7ddf7a0caa (patch)
treef1096f56bf0c23189e2e82b909938638ac9b7efb /sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
parent53612ae086ce9e171633a17392eb88c008650b8e (diff)
gentoo auto-resync : 21:09:2022 - 11:25:44
Diffstat (limited to 'sys-libs/libcxx/libcxx-16.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-16.0.0.9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
index 07049e01ed34..28c4cca66346 100644
--- a/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
@@ -23,16 +23,14 @@ RDEPEND="
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -91,9 +89,7 @@ src_configure() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -139,9 +135,6 @@ multilib_src_configure() {
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"