summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-11.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-libs/libcxx/libcxx-11.1.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-libs/libcxx/libcxx-11.1.0.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-11.1.0.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/sys-libs/libcxx/libcxx-11.1.0.ebuild b/sys-libs/libcxx/libcxx-11.1.0.ebuild
index 26e9ff250d52..16172647c295 100644
--- a/sys-libs/libcxx/libcxx-11.1.0.ebuild
+++ b/sys-libs/libcxx/libcxx-11.1.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://libcxx.llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~riscv x86 ~x64-macos"
IUSE="elibc_glibc elibc_musl +libcxxabi +libunwind static-libs test"
REQUIRED_USE="libunwind? ( libcxxabi )"
RESTRICT="!test? ( test )"
@@ -35,6 +35,7 @@ BDEPEND="
DOCS=( CREDITS.TXT )
LLVM_COMPONENTS=( libcxx{,abi} llvm/{cmake/modules,utils/llvm-lit} )
+LLVM_PATCHSET=11.1.0-1
llvm.org_set_globals
python_check_deps() {
@@ -58,14 +59,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
- # out-of-tree build.
- eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
-
- llvm.org_src_prepare
-}
-
test_compiler() {
$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
<<<'int main() { return 0; }' &>/dev/null