summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-libs/libcxx/libcxx-11.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.9999.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
index 5a3729e82ad3..c8f3b48d30c5 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
@@ -3,13 +3,14 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
-LLVM_COMPONENTS=( libcxx )
+# libcxxabi is required unconditionally now
+LLVM_COMPONENTS=( libcxx{,abi} )
llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
@@ -56,12 +57,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {
@@ -146,7 +141,7 @@ multilib_src_configure() {
multilib_src_test() {
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-libcxx
+ cmake-utils_src_make check-cxx
}
# Usage: deps