summaryrefslogtreecommitdiff
path: root/sys-libs/libcap-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/libcap-ng
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/libcap-ng')
-rw-r--r--sys-libs/libcap-ng/Manifest5
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild100
-rw-r--r--sys-libs/libcap-ng/metadata.xml14
3 files changed, 119 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/Manifest b/sys-libs/libcap-ng/Manifest
new file mode 100644
index 000000000000..50189955ef7b
--- /dev/null
+++ b/sys-libs/libcap-ng/Manifest
@@ -0,0 +1,5 @@
+DIST libcap-ng-0.7.8.tar.gz 447946 SHA256 c21af997445cd4107a55d386f955c5ea6f6e96ead693e9151277c0ab5f97d05f SHA512 c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756 WHIRLPOOL a56ee901f301c4c2e0353e2b9e38938fcd6efbb9394d60af6c7045967e6a310fd19b658617b362f14489a75da64a69e82a3afcada97f898c2ab25fad6fb6603d
+EBUILD libcap-ng-0.7.8.ebuild 2308 SHA256 8fcf3babd9e48b83098ef5561b680a372ba4f093f361ba3fe2f34b8a7a6110ad SHA512 b61063ef706671a2ccc15770d5687f2abc15a9b7c16ee7386db4b7e605f28094ad88b51c2d001cee018eb76900a10236b250eab741c8614e6541119fffa86461 WHIRLPOOL 81ca4a312121a80cf3e5fed1ef07ed0b698045e0a6af29907e695f110045d1a0765be0cc204443192e8f49899b4d75bbcc022bcd38b1503eca97fb7efc48416c
+MISC ChangeLog 5981 SHA256 95fae46ed32a503e1542fad7542bc0fb56e8123de570dd6d5628f6eaa2f5c901 SHA512 afc8440dc05497a72381e96b1762983ead83eb67d4002ab9055150f6d729c9763e9be08a91494f3fbdf557ee910eaa1272496df4f258ed6a0d644f8c39bd7394 WHIRLPOOL 2392f36fe99fa16b12ea98aa4c8f449cee2c8192cc34136053ce139500c9cb254a4339305fd6bfdfb965723a8345e3471c6516d6f4bb8697f9603fd702c53be4
+MISC ChangeLog-2015 10433 SHA256 559a152b35084b04940b619faff0216fb5f9055caa52594096fa7a3444f3616d SHA512 678b1fe48a396ffd2bd939b2828ef9cf9aa4175701f2aea8c6fbbd608c5038c518e98969891b2b2eab65992edf84c57818bc8a7b27f593c24414907ad5767961 WHIRLPOOL 549ea31a5cae98a96e177e6dd9ca75067a9108bc5e352e369fc4f8485ba735e3ab1b973c631eda1d21aba6444d1a39d6179e4e0d34c03933fde01bb76680794b
+MISC metadata.xml 580 SHA256 d6000e84fe72c4f6b507c04edda36269aed6a1cab6aaf430eab08ad3592bf48c SHA512 51d670d97a94c8c668a4580bf6106a5b027b4d8d0c2f27ca88a508e60ece5a5390b619f0368c8111f2b843748a9ad31f1804c2a60df91ae1717a2c8b2a7aedc3 WHIRLPOOL e29b31c47bdb74ea61049e6cebd897e4147c9d5acefbcd1c1f752cf8cc5893047b5918805bbc9b8553eec3b68319825a1c9a5c48f987b6f788e6415bebac8c7e
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild
new file mode 100644
index 000000000000..4d8132b1ac0b
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools-utils flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~arm-linux ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+
+ autotools-utils_src_prepare
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ # set up the library build
+ local myeconfargs=( --without-python --without-python3 )
+ autotools-utils_src_configure
+
+ # set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ myeconfargs=( --with-python --without-python3 )
+ else
+ myeconfargs=( --with-python --with-python3 )
+ fi
+ autotools-utils_src_configure
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_compile() {
+ local CFLAGS=${CFLAGS}
+
+ python_is_python3 || CFLAGS+=" -fno-strict-aliasing"
+
+ emake "${@}" \
+ -C "${BUILD_DIR}"/bindings/python
+ }
+
+ # help build system find the right objects
+ python_foreach_impl python_compile \
+ VPATH="${BUILD_DIR}"/bindings/python \
+ LIBS="${BUILD_DIR}"/src/libcap-ng.la
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ autotools-utils_src_test
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_compile -C bindings/python check \
+ VPATH="${BUILD_DIR}"/bindings/python:"${S}"/bindings/python/test
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_install -C bindings/python \
+ VPATH="${BUILD_DIR}"/bindings/python
+ fi
+}
diff --git a/sys-libs/libcap-ng/metadata.xml b/sys-libs/libcap-ng/metadata.xml
new file mode 100644
index 000000000000..9aa642f3201d
--- /dev/null
+++ b/sys-libs/libcap-ng/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<longdescription>
+ The libcap-ng library is intended to make programming with POSIX
+ capabilities much easier than the traditional libcap library. It includes
+ utilities that can analyse all currently running applications and print
+ out any capabilities and whether or not it has an open ended bounding set.
+</longdescription>
+</pkgmetadata>