summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /sys-libs/libblockdev
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/Manifest1
-rw-r--r--sys-libs/libblockdev/libblockdev-2.28-r2.ebuild136
2 files changed, 137 insertions, 0 deletions
diff --git a/sys-libs/libblockdev/Manifest b/sys-libs/libblockdev/Manifest
index 0594097dbb59..c218869c9b55 100644
--- a/sys-libs/libblockdev/Manifest
+++ b/sys-libs/libblockdev/Manifest
@@ -1,5 +1,6 @@
AUX libblockdev-2.28-sh_tests.patch 1552 BLAKE2B 3b26cf271a0cb2a0f51ecffe51c9caf9a0ac1c65aecb5adc845a2721f3ac7178df7c994b7647b4fa1bbfd27baf072325bffedf723555c39e164f7d7645163090 SHA512 11fc498db4ed1d3a9e5a9288e1137d64f7581cc7b2d265292f7a3899ef5cfc6d63138fef7f87695abd9d518fa1c74a8bd98ebb54038211eeb0afe7964d85c6c4
DIST libblockdev-2.28.tar.gz 925698 BLAKE2B 63ac7ab5bd02c1ef1848d0b252e09fe721cfe86258f063b7bab616766cbc56311707dcb2dd3a1fadf0e0840187f121aa178fd5959500cd590b846238a9d3e36e SHA512 9e01c41db4f728c8e81e710c6bb4725bbe34b3a7de25ff7f57b7b88ca6b7b5debbe858947585d314770036b2c3c533f9f8ff3d038b7ca50eee3d18f9fbe0d392
EBUILD libblockdev-2.28-r1.ebuild 3000 BLAKE2B 3aa70b52c0e0ff70de8b7f471d5fcaf8c7f99bc6a18a32ef0b714eb249c83186e0f85bce6c70c48bab906a6e62e76ca94293459042aea54dbfe6887b1371d765 SHA512 834a2bc93c7d9818132d4da6607e5259e79d2fe29e01dfd14881815a11d3ca116596d0d2e788af99a9ccb955731c4b9fb8c4f9ea51e17b81d20f0e3666036625
+EBUILD libblockdev-2.28-r2.ebuild 2939 BLAKE2B b0018832c9365f95fde574fb705cbfd57ff0f1cea167b096557d7ff0a78ef18175f0f592ecbdee92c2e1a9d6f10517154609a3ed70d43d3fe0ccfb697ccad3a5 SHA512 47df44ffd1a59704d04a43835c700e6751b2e5d6777d3f147defeb439f050430597e9e22041fddab14bf2b321d29e3095b3bf02e46549ad13ae6862bfd6d9270
EBUILD libblockdev-9999.ebuild 2733 BLAKE2B b7dd95006279e4717687664c9fa6cff563cb0ff1b8500c0b962742c9b8a440ba51f2e4550cf251a3608c77c17d5bc7f8343372a89052d034b1801e91988044fe SHA512 e0b750ff1819f6de9500855ee87ca55287b7fff6266eda78f9f3c5cc35bb2ea10d2b1d894a8fad90003669144ae10ef533207a3af175aa456849696285792f94
MISC metadata.xml 1233 BLAKE2B 68512209e8f458b5b52a9d82eb86c1c831837681b2976d5050c578c3b3fdb032640c4cc99da9621aae7c061ae8332825ea5010a8f1138fbbbc34e92fccbeddeb SHA512 eb47faef934a8eafe1beeea6f901ddd6b0e7202823f57b3848f6ef131b2a5ffc968740d980a68163696d3de34a98ebef8561e63d26ffe213a42e1022577a9270
diff --git a/sys-libs/libblockdev/libblockdev-2.28-r2.ebuild b/sys-libs/libblockdev/libblockdev-2.28-r2.ebuild
new file mode 100644
index 000000000000..1be0372d3a14
--- /dev/null
+++ b/sys-libs/libblockdev/libblockdev-2.28-r2.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1 xdg-utils
+
+DESCRIPTION="A library for manipulating block devices"
+HOMEPAGE="https://github.com/storaged-project/libblockdev"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
+ BDEPEND="
+ sys-devel/autoconf-archive
+ "
+else
+ MY_PV="${PV}-1"
+ SRC_URI="https://github.com/storaged-project/${PN}/releases/download/${MY_PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="bcache +cryptsetup device-mapper dmraid escrow gtk-doc introspection lvm kbd test +tools vdo"
+# Tests require root. In a future release, we may be able to run a smaller
+# subset with new run_tests.py arguments.
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.2
+ dev-libs/libbytesize
+ sys-apps/gptfdisk
+ >=sys-apps/kmod-19
+ >=sys-apps/util-linux-2.27
+ >=sys-block/parted-3.1
+ cryptsetup? (
+ escrow? (
+ >=dev-libs/nss-3.18.0
+ dev-libs/volume_key
+ )
+ >=sys-fs/cryptsetup-1.6.7:=
+ )
+ device-mapper? ( sys-fs/lvm2 )
+ dmraid? (
+ sys-fs/dmraid
+ sys-fs/lvm2
+ )
+ lvm? (
+ sys-fs/lvm2
+ virtual/udev
+ )
+ vdo? ( dev-libs/libyaml )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND+="
+ dev-util/gtk-doc-am
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( >=dev-libs/gobject-introspection-1.3.0 )
+ test? (
+ $(python_gen_cond_dep '
+ dev-libs/libbytesize[python,${PYTHON_USEDEP}]
+ ')
+ sys-block/targetcli-fb
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ escrow? ( cryptsetup )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.28-sh_tests.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_environment_reset #623992
+ default
+
+ # https://bugs.gentoo.org/744289
+ find -type f \( -name "Makefile.am" -o -name "configure.ac" \) -print0 \
+ | xargs --null sed "s@ -Werror@@" -i || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-btrfs
+ --with-fs
+ --with-part
+ --with-python3
+ --without-mpath
+ --without-nvdimm
+ --without-python2
+ $(use_enable introspection)
+ $(use_enable test tests)
+ $(use_with bcache)
+ $(use_with cryptsetup crypto)
+ $(use_with device-mapper dm)
+ $(use_with dmraid)
+ $(use_with escrow)
+ $(use_with gtk-doc)
+ $(use_with kbd)
+ $(use_with lvm lvm)
+ $(use_with lvm lvm-dbus)
+ $(use_with tools)
+ $(use_with vdo)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See http://storaged.org/libblockdev/ch03.html
+ # The 'check' target just does Pylint.
+ # ... but it needs root.
+ emake test
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+ # This is installed even with USE=-lvm, but libbd_lvm are omitted so it
+ # doesn't work at all.
+ if ! use lvm ; then
+ rm -f "${ED}"/usr/bin/lvm-cache-stats || die
+ fi
+ python_optimize #718576
+}