summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev/libblockdev-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
commit49307b439ea0ae14beb0772de83e70297ae8356c (patch)
tree02f22afc29810c4558bf87d13c56f288d43fecc3 /sys-libs/libblockdev/libblockdev-9999.ebuild
parent99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (diff)
gentoo auto-resync : 09:07:2023 - 04:23:59
Diffstat (limited to 'sys-libs/libblockdev/libblockdev-9999.ebuild')
-rw-r--r--sys-libs/libblockdev/libblockdev-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/sys-libs/libblockdev/libblockdev-9999.ebuild b/sys-libs/libblockdev/libblockdev-9999.ebuild
index 73e19fc076a1..59bd04d7fe4e 100644
--- a/sys-libs/libblockdev/libblockdev-9999.ebuild
+++ b/sys-libs/libblockdev/libblockdev-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
@@ -20,8 +20,8 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
LICENSE="LGPL-2+"
-SLOT="0"
-IUSE="bcache +cryptsetup device-mapper dmraid escrow gtk-doc introspection lvm kbd +nvme test +tools"
+SLOT="0/3" # subslot is SOVERSION
+IUSE="+cryptsetup device-mapper escrow gtk-doc introspection lvm +nvme test +tools"
# Tests require root. In a future release, we may be able to run a smaller
# subset with new run_tests.py arguments.
RESTRICT="!test? ( test ) test"
@@ -29,6 +29,7 @@ RESTRICT="!test? ( test ) test"
RDEPEND="
>=dev-libs/glib-2.42.2
dev-libs/libbytesize
+ sys-apps/gptfdisk
>=sys-apps/kmod-19
>=sys-apps/util-linux-2.27
>=sys-block/parted-3.1
@@ -37,13 +38,10 @@ RDEPEND="
>=dev-libs/nss-3.18.0
dev-libs/volume_key
)
- >=sys-fs/cryptsetup-1.6.7:=
+ >=sys-apps/keyutils-1.5.0:=
+ >=sys-fs/cryptsetup-2.3.0:=
)
device-mapper? ( sys-fs/lvm2 )
- dmraid? (
- sys-fs/dmraid
- sys-fs/lvm2
- )
lvm? (
sys-fs/lvm2
virtual/udev
@@ -60,6 +58,12 @@ BDEPEND+="
dev-util/gtk-doc-am
gtk-doc? ( dev-util/gtk-doc )
introspection? ( >=dev-libs/gobject-introspection-1.3.0 )
+ test? (
+ $(python_gen_cond_dep '
+ dev-libs/libbytesize[python,${PYTHON_USEDEP}]
+ ')
+ sys-block/targetcli-fb
+ )
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -90,13 +94,10 @@ src_configure() {
--without-nvdimm
$(use_enable introspection)
$(use_enable test tests)
- $(use_with bcache)
$(use_with cryptsetup crypto)
$(use_with device-mapper dm)
- $(use_with dmraid)
$(use_with escrow)
$(use_with gtk-doc)
- $(use_with kbd)
$(use_with lvm lvm)
$(use_with lvm lvm-dbus)
$(use_with nvme)