summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev/libblockdev-2.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
commitdb063b515939ab15261136b24e4bc44386335c0c (patch)
tree54c06cac96a32ba6fe5f69e52616a2ab27bbb6d6 /sys-libs/libblockdev/libblockdev-2.24.ebuild
parent8b4ace9c50842c5b83401ea7b179dcab940387e1 (diff)
gentoo resync : 24.09.2020
Diffstat (limited to 'sys-libs/libblockdev/libblockdev-2.24.ebuild')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.24.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.24.ebuild b/sys-libs/libblockdev/libblockdev-2.24.ebuild
index 2d41db827580..04aa60d48088 100644
--- a/sys-libs/libblockdev/libblockdev-2.24.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.24.ebuild
@@ -4,12 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1 xdg-utils
+inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
HOMEPAGE="https://github.com/storaged-project/libblockdev"
if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
BDEPEND="
sys-devel/autoconf-archive
@@ -73,7 +73,12 @@ pkg_setup() {
src_prepare() {
xdg_environment_reset #623992
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ # https://bugs.gentoo.org/744289
+ find -type f \( -name "Makefile.am" -o -name "configure.ac" \) -print0 \
+ | xargs --null sed "s@ -Werror@@" -i || die
+
+ eautoreconf
}
src_configure() {