summaryrefslogtreecommitdiff
path: root/sys-libs/glibc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 19:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 19:03:28 +0000
commitf03f06fb7152586e3084ebabe54d93f28da8bf6d (patch)
treef476e8d7696af448ddbe831c85e80189b64bc411 /sys-libs/glibc
parentc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (diff)
gentoo auto-resync : 09:01:2024 - 19:03:28
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild12
2 files changed, 2 insertions, 12 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 53a2105d9fa4..682b1d6a7f2e 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -53,5 +53,5 @@ EBUILD glibc-2.37-r9.ebuild 52996 BLAKE2B fad38719af67c7a94b8f8f920ccb1fbf6849da
EBUILD glibc-2.38-r7.ebuild 54065 BLAKE2B 284b71e90960020677ca3909e65079b793e893b3133adcd0eac5b9bf47cadc35848a3038ee85328ad459d8fac69ee470f23bf679bb21d7c20259dc12e22c22c5 SHA512 115b0926399f9ebb12d89fad41cebc93a0cecf1dcff8e582a8f1e354e5e0424e2eafde6430a39bcd8ab9b4e18e22a519679c2772854b94c11b8c7df10739081d
EBUILD glibc-2.38-r8.ebuild 54130 BLAKE2B 4cf3a62d6eeee440f100c63aae99a680fa4f064aa6c8c89a2e982635cfb77e72fcb685da273df38a7f6be479debeba223fe64e967373d89d79194f2ee1978700 SHA512 6214abbcb03647e816d144ead6658bae1152d84c0bb32773307014994d9d2bd3c08b67b6c53da8b7dca228c97b56c54a7539f1d69f31a613108186bbe145c095
EBUILD glibc-2.38-r9.ebuild 54291 BLAKE2B 8e193ad79adb26d434e2652fffdef76253e2a12d3bf4216b627a188b5dcab078e6b37bc28b4f37f4e5b7480823a1fd56020e8e8653866f856bcc3af74810431c SHA512 f97e1a33c0c731e8f4fa7e45ff6ac2fdb869e08da8de824d5d1feb1841c4da5567e3c0a67c8f32357ee5044702f74272953d3f3cf67ba446a6185cacb44993a7
-EBUILD glibc-9999.ebuild 54300 BLAKE2B ebf590af16a50a259a1120360803ce96bd3d3b84eba1eb2fc097129c3e8049dce45ab4b8c3b010d2813e30c4f8a6de7a3f0cfd976652a1bacb3bf2f10deb453c SHA512 6a223baa1e506690d095f07182ab7a76c488071ab38180824ff3be1a76bd27d5c28bd1464a4c42f609abe663e9a07531843cd45e991f1fb200d8f52eead92d39
+EBUILD glibc-9999.ebuild 53860 BLAKE2B e72fbe9cfe7ba9e782c5b38d04923b1baf9133420486c77be4cd2e25b18853aee6d1556249c23004d14600f2d5585f4e5aee2fcdd50a36097b58b5073a88c65b SHA512 19104d3b3e7176b980025f856cc7553350aea95290ea21d9afbce4a6d1e909fc035cab5870342827106aa81da1919d2ce266aa8eea568868cdd5830f560ba5cb
MISC metadata.xml 2142 BLAKE2B 765ba540eb10afccd1bade4de56f0c13ce269225500a62d1d17328194de69e7fa15d359a14eac6bfa8a36df45344db3d52f5e1811b174cf1fa2bfb95ad7760a7 SHA512 2f4a148c076a0967663d14e76b85a698ddae7093ff299b0dc95a6c3b00957c9bf73443f2bace9670eb62a45465efbcca892bb52b6aac8577acb2bc5f74a7397c
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a1efdfa51e2c..4740163cf11f 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1082,16 +1082,6 @@ glibc_do_configure() {
echo "$@"
"$@" || die "failed to configure glibc"
- # ia64 static cross-compilers are a pita in so much that they
- # can't produce static ELFs (as the libgcc.a is broken). so
- # disable building of the programs for those targets if it
- # doesn't work.
- # XXX: We could turn this into a compiler test, but ia64 is
- # the only one that matters, so this should be fine for now.
- if is_crosscompile && [[ ${CTARGET} == ia64* ]] ; then
- sed -i '1i+link-static = touch $@' config.make
- fi
-
# If we're trying to migrate between ABI sets, we need
# to lie and use a local copy of gcc. Like if the system
# is built with MULTILIB_ABIS="amd64 x86" but we want to
@@ -1117,7 +1107,7 @@ glibc_headers_configure() {
# the best here ...
local v vars=(
ac_cv_header_cpuid_h=yes
- libc_cv_{386,390,alpha,arm,hppa,ia64,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes
+ libc_cv_{386,390,alpha,arm,hppa,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes
libc_cv_asm_cfi_directives=yes
libc_cv_broken_visibility_attribute=no
libc_cv_c_cleanup=yes