summaryrefslogtreecommitdiff
path: root/sys-libs/glibc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-12 01:06:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-12 01:06:33 +0000
commit5c273534e10d0e86a5941f9ba9c4ed87b90f0dd1 (patch)
tree6fc2a78d8d62da19b832c6506988b3c5bcccf6f4 /sys-libs/glibc
parent427aed27427f356a75db3288d7b96ce7e2a044b2 (diff)
gentoo auto-resync : 12:01:2024 - 01:06:32
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
2 files changed, 3 insertions, 5 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 16fc64d7e4f7..7e394381434a 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -49,5 +49,5 @@ EBUILD glibc-2.36-r8.ebuild 52466 BLAKE2B fc59a2935c5e9487585449477ae7a0db2b0054
EBUILD glibc-2.37-r7.ebuild 52827 BLAKE2B 34910a55ba94e09fed6c8f9decd963c56c4a19b46bf0e6ba2fdcd82b9b382af64232321c8b7691ba7a969d55b72e2707d83a88954c1a3d5397ea94eecd7c21f6 SHA512 468a7bb03b3c90e384a4c1f321647c01cfc8f34e214b2e9a1d1e16d4ff7c8b91a5b39f0e29c6072e66beaa908f58c6e441119d16a043f7308a1596c083c5c364
EBUILD glibc-2.37-r9.ebuild 52996 BLAKE2B fad38719af67c7a94b8f8f920ccb1fbf6849daa96a4f02df98f7e85e11ae75ae036cd228396691f7797046b6fb2c6aa67bc96f4af7222f012cafe1e39b963e8a SHA512 2b4d3356da06f6265075fec2022c8563e9a9fa49546b1ef2b2d952d98f175d3ba2c1673f4083f6daf5c7f44f140fc01c44c2e6179cb9e421cf36fcd6224a7c64
EBUILD glibc-2.38-r9.ebuild 54291 BLAKE2B 8e193ad79adb26d434e2652fffdef76253e2a12d3bf4216b627a188b5dcab078e6b37bc28b4f37f4e5b7480823a1fd56020e8e8653866f856bcc3af74810431c SHA512 f97e1a33c0c731e8f4fa7e45ff6ac2fdb869e08da8de824d5d1feb1841c4da5567e3c0a67c8f32357ee5044702f74272953d3f3cf67ba446a6185cacb44993a7
-EBUILD glibc-9999.ebuild 53860 BLAKE2B e72fbe9cfe7ba9e782c5b38d04923b1baf9133420486c77be4cd2e25b18853aee6d1556249c23004d14600f2d5585f4e5aee2fcdd50a36097b58b5073a88c65b SHA512 19104d3b3e7176b980025f856cc7553350aea95290ea21d9afbce4a6d1e909fc035cab5870342827106aa81da1919d2ce266aa8eea568868cdd5830f560ba5cb
+EBUILD glibc-9999.ebuild 53794 BLAKE2B f5280ae2cd9dcfb0f80a88710628f6c39659518577fc79b952c337c7aa59775d00cb6a19b6e46523022e72bb1042dcdace92b87c12e63bb81452d0190e0875ae SHA512 b3cd7510593768ac6a98c8cf34cd39dbfbae2f79bc90a337a30d3b726dfffa582976524abfcf05768a6b72b7e8939ad2a209514a206bd51b6195a778ce2d6e27
MISC metadata.xml 2142 BLAKE2B 765ba540eb10afccd1bade4de56f0c13ce269225500a62d1d17328194de69e7fa15d359a14eac6bfa8a36df45344db3d52f5e1811b174cf1fa2bfb95ad7760a7 SHA512 2f4a148c076a0967663d14e76b85a698ddae7093ff299b0dc95a6c3b00957c9bf73443f2bace9670eb62a45465efbcca892bb52b6aac8577acb2bc5f74a7397c
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 4740163cf11f..cd4b039899b3 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -47,7 +47,7 @@ fi
SRC_URI+=" multilib-bootstrap? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
SRC_URI+=" systemd? ( https://gitweb.gentoo.org/proj/toolchain/glibc-systemd.git/snapshot/glibc-systemd-${GLIBC_SYSTEMD_VER}.tar.gz )"
-IUSE="audit caps cet compile-locales +crypt custom-cflags doc gd hash-sysv-compat headers-only +multiarch multilib multilib-bootstrap nscd perl profile selinux +ssp stack-realign +static-libs suid systemd systemtap test vanilla"
+IUSE="audit caps cet compile-locales custom-cflags doc gd hash-sysv-compat headers-only +multiarch multilib multilib-bootstrap nscd perl profile selinux +ssp stack-realign +static-libs suid systemd systemtap test vanilla"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1038,7 +1038,6 @@ glibc_do_configure() {
--libexecdir='$(libdir)'/misc/glibc
--with-bugurl=https://bugs.gentoo.org/
--with-pkgversion="$(glibc_banner)"
- $(use_enable crypt)
$(use_multiarch || echo --disable-multi-arch)
$(use_enable systemtap)
$(use_enable nscd)
@@ -1194,7 +1193,6 @@ glibc_headers_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--with-headers=$(build_eprefix)$(alt_build_headers)
--prefix="$(host_eprefix)/usr"
- $(use_enable crypt)
${EXTRA_ECONF}
)
@@ -1632,7 +1630,7 @@ pkg_preinst() {
# Keep around libcrypt so that Perl doesn't break when merging libxcrypt
# (libxcrypt is the new provider for now of libcrypt.so.{1,2}).
# bug #802207
- if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]" && ! has preserve-libs ${FEATURES}; then
+ if has_version "${CATEGORY}/${PN}[crypt]" && ! has preserve-libs ${FEATURES}; then
PRESERVED_OLD_LIBCRYPT=1
cp -p "${EROOT}/$(get_libdir)/libcrypt$(get_libname 1)" "${T}/libcrypt$(get_libname 1)" || die
else