summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-libs/glibc/glibc-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild52
1 files changed, 19 insertions, 33 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 9284afea8665..46dde2c6ce3a 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit prefix eutils versionator toolchain-funcs flag-o-matic gnuconfig \
+inherit prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuconfig \
multilib systemd multiprocessing
DESCRIPTION="GNU libc C library"
@@ -18,7 +18,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://sourceware.org/git/glibc.git"
inherit git-r3
else
- # KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
KEYWORDS=""
SRC_URI="mirror://gnu/glibc/${P}.tar.xz"
fi
@@ -28,12 +28,12 @@ RELEASE_VER=${PV}
GCC_BOOTSTRAP_VER=20180511
# Gentoo patchset
-PATCH_VER=8
+PATCH_VER=10
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
-IUSE="audit caps cet compile-locales doc gd hardened headers-only +multiarch multilib nscd profile selinux suid systemtap test vanilla"
+IUSE="audit caps cet compile-locales doc gd headers-only +multiarch multilib nscd profile selinux suid systemtap test vanilla"
# Minimum kernel version that glibc requires
MIN_KERN_VER="3.2.0"
@@ -61,7 +61,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
# We need a new-enough binutils/gcc to match upstream baseline.
-# Also we need to make sure our binutils/gcc supports TLS.
+# Also we need to make sure our binutils/gcc supports TLS,
+# and that gcc already contains the hardened patches.
COMMON_DEPEND="
nscd? ( selinux? (
audit? ( sys-process/audit )
@@ -91,13 +92,13 @@ RDEPEND="${COMMON_DEPEND}
if [[ ${CATEGORY} == cross-* ]] ; then
DEPEND+=" !headers-only? (
>=${CATEGORY}/binutils-2.24
- >=${CATEGORY}/gcc-4.9
+ >=${CATEGORY}/gcc-6
)"
[[ ${CATEGORY} == *-linux* ]] && DEPEND+=" ${CATEGORY}/linux-headers"
else
DEPEND+="
>=sys-devel/binutils-2.24
- >=sys-devel/gcc-4.9
+ >=sys-devel/gcc-6
virtual/os-headers
"
RDEPEND+=" vanilla? ( !sys-libs/timezone-data )"
@@ -259,18 +260,18 @@ setup_target_flags() {
sparc64-*)
case $(get-flag mcpu) in
niagara[234])
- if version_is_at_least 2.8 ; then
+ if ver_test -ge 2.8 ; then
cpu="sparc64v2"
- elif version_is_at_least 2.4 ; then
+ elif ver_test -ge 2.4 ; then
cpu="sparc64v"
- elif version_is_at_least 2.2.3 ; then
+ elif ver_test -ge 2.2.3 ; then
cpu="sparc64b"
fi
;;
niagara)
- if version_is_at_least 2.4 ; then
+ if ver_test -ge 2.4 ; then
cpu="sparc64v"
- elif version_is_at_least 2.2.3 ; then
+ elif ver_test -ge 2.2.3 ; then
cpu="sparc64b"
fi
;;
@@ -288,20 +289,20 @@ setup_target_flags() {
sparc-*)
case $(get-flag mcpu) in
niagara[234])
- if version_is_at_least 2.8 ; then
+ if ver_test -ge 2.8 ; then
cpu="sparcv9v2"
- elif version_is_at_least 2.4 ; then
+ elif ver_test -ge 2.4 ; then
cpu="sparcv9v"
- elif version_is_at_least 2.2.3 ; then
+ elif ver_test -ge 2.2.3 ; then
cpu="sparcv9b"
else
cpu="sparcv9"
fi
;;
niagara)
- if version_is_at_least 2.4 ; then
+ if ver_test -ge 2.4 ; then
cpu="sparcv9v"
- elif version_is_at_least 2.2.3 ; then
+ elif ver_test -ge 2.2.3 ; then
cpu="sparcv9b"
else
cpu="sparcv9"
@@ -371,21 +372,6 @@ setup_flags() {
append-flags -O2 -fno-strict-aliasing
filter-flags '-fstack-protector*'
-
- # Starting with gcc-6 (and fully upstreamed pie patches) we control
- # default enabled/disabled pie via use flags. So nothing to do
- # here then. #618160
- if [[ $(gcc-major-version) -lt 6 ]]; then
- if use hardened && tc-enables-pie ; then
- # Force PIC macro definition for all compilations since they're all
- # either -fPIC or -fPIE with the default-PIE compiler.
- append-cppflags -DPIC
- else
- # Don't build -fPIE without the default-PIE compiler and the
- # hardened-pie patch
- filter-flags -fPIE
- fi
- fi
}
want_tls() {
@@ -433,7 +419,7 @@ use_multiarch() {
sparc) nver="2.21" ;;
*) return 1 ;;
esac
- version_is_at_least ${nver} ${bver}
+ ver_test ${bver} -ge ${nver}
}
# Setup toolchain variables that had historically been defined in the