summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /sys-libs/glibc/glibc-9999.ebuild
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2b4e84c98db7..a0250a2928fc 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -6,13 +6,10 @@ EAPI=8
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-# Please keep the python line in BDEPEND updated and do NOT use eclasses pr
-# ${PYTHON_DEPS} (since they are too strict and lead to problems with the
-# package order during upgrades).
-
+PYTHON_COMPAT=( python3_{9..11} )
TMPFILES_OPTIONAL=1
-inherit prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
+inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
multilib systemd multiprocessing tmpfiles
DESCRIPTION="GNU libc C library"
@@ -42,7 +39,7 @@ MIN_PAX_UTILS_VER="1.3.3"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
- #KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="mirror://gnu/glibc/${P}.tar.xz"
SRC_URI+=" https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
fi
@@ -104,7 +101,7 @@ IDEPEND="
!compile-locales? ( sys-apps/locale-gen )
"
BDEPEND="
- || ( dev-lang/python:3.11 dev-lang/python:3.10 dev-lang/python:3.9 )
+ ${PYTHON_DEPS}
>=app-misc/pax-utils-${MIN_PAX_UTILS_VER}
sys-devel/bison
compile-locales? ( sys-apps/locale-gen )
@@ -867,6 +864,13 @@ pkg_pretend() {
upgrade_warning
}
+# pkg_setup
+
+pkg_setup() {
+ # see bug 682570
+ [[ -z ${BOOTSTRAP_RAP} ]] && python-any-r1_pkg_setup
+}
+
# src_unpack
src_unpack() {
@@ -986,6 +990,7 @@ glibc_do_configure() {
myconf+=(
--disable-werror
--enable-bind-now
+ --enable-fortify-source
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
@@ -1017,15 +1022,10 @@ glibc_do_configure() {
# https://bugs.gentoo.org/753740
libc_cv_complocaledir='${exec_prefix}/lib/locale'
- # -march= option tricks build system to infer too
- # high ISA level: https://sourceware.org/PR27318
- libc_cv_include_x86_isa_level=no
-
- # Explicit override of https://sourceware.org/PR27991
- # exposes a bug in glibc's configure:
- # https://sourceware.org/PR27991
- libc_cv_have_x86_lahf_sahf=no
- libc_cv_have_x86_movbe=no
+ # On aarch64 there is no way to override -mcpu=native, and if
+ # the current cpu does not support SVE configure fails.
+ # Let's boldly assume our toolchain can always build SVE instructions.
+ libc_cv_aarch64_sve_asm=yes
${EXTRA_ECONF}
)